aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/dvdstyler
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-22 01:30:54 +0800
committerwg <wg@FreeBSD.org>2013-10-22 01:30:54 +0800
commit225757b617759e712fd560684d75013835194dc6 (patch)
tree19e1c35c3d93c6f4032ddc6e7d0e912d390e27f5 /multimedia/dvdstyler
parentc68eb12fdb6adc125c820bd4ba0c7b971347703b (diff)
downloadfreebsd-ports-gnome-225757b617759e712fd560684d75013835194dc6.tar.gz
freebsd-ports-gnome-225757b617759e712fd560684d75013835194dc6.tar.zst
freebsd-ports-gnome-225757b617759e712fd560684d75013835194dc6.zip
multimedia/dvdstyler: link against ffmpeg
- Link against ffmpeg - Allow staging - USES desktop-file-utils gmake - Convert lib depends to new format
Diffstat (limited to 'multimedia/dvdstyler')
-rw-r--r--multimedia/dvdstyler/Makefile27
-rw-r--r--multimedia/dvdstyler/pkg-plist3
2 files changed, 9 insertions, 21 deletions
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index d78339013924..c0d8411072d4 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -20,9 +20,9 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
mplex:${PORTSDIR}/multimedia/mjpegtools \
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
docbook-sk>=4.1.2:${PORTSDIR}/textproc/docbook-sk \
- xmlto:${PORTSDIR}/textproc/xmlto
-LIB_DEPENDS= exif:${PORTSDIR}/graphics/libexif \
- avcodec1:${PORTSDIR}/multimedia/ffmpeg1
+ xmlto:${PORTSDIR}/textproc/xmlto
+LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
wxsvg>=1.1.14:${PORTSDIR}/graphics/wxsvg \
dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
@@ -33,27 +33,15 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
OPTIONS_DEFINE= GNOME DOCS
USE_BZIP2= yes
-USES= gettext pkgconfig
+USES= desktop-file-utils gettext gmake pkgconfig
USE_WX= 2.8
WX_COMPS= wx svg
WX_CONF_ARGS= absolute
-USE_GNOME= desktopfileutils
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBAV_CFLAGS="${LIBAV_CFLAGS}" LIBAV_LIBS="${LIBAV_LIBS}" \
- ac_cv_path_FFMPEG_PATH="${LOCALBASE}/bin/ffmpeg1"
-MAKE_ENV= AM_CPPFLAGS="${LIBAV_CFLAGS}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= dvdstyler.1
-
-LIBAV_PC= libavcodec1 libavformat1 libavutil1 libswscale1
-LIBAV_CFLAGS= $$(pkg-config --cflags ${LIBAV_PC})
-LIBAV_LIBS= $$(pkg-config --libs ${LIBAV_PC})
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNOME}
@@ -91,14 +79,15 @@ post-patch:
${WRKSRC}/src/BurnDlg.cpp
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|g' \
${WRKSRC}/src/Config.h
+ @${REINPLACE_CMD} -e 's|CodecID|AVCodecID|g' \
+ ${WRKSRC}/src/mediaenc_ffmpeg.cpp
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in AUTHORS ChangeLog INSTALL README
- (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
.endif
- @-update-desktop-database
.include <bsd.port.mk>
diff --git a/multimedia/dvdstyler/pkg-plist b/multimedia/dvdstyler/pkg-plist
index 6616602d1123..4b5374d7b776 100644
--- a/multimedia/dvdstyler/pkg-plist
+++ b/multimedia/dvdstyler/pkg-plist
@@ -158,6 +158,7 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/templates/Travel/travel.png
%%DATADIR%%/templates/Travel/travelWS.dvdt
%%DATADIR%%/templates/Travel/travelWS.png
+man/man1/dvdstyler.1.gz
share/locale/ar/LC_MESSAGES/dvdstyler.mo
share/locale/ca/LC_MESSAGES/dvdstyler.mo
share/locale/cs/LC_MESSAGES/dvdstyler.mo
@@ -211,5 +212,3 @@ share/pixmaps/dvdstyler.png
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true