aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ffmpeg0
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-11-15 03:34:12 +0800
committerjbeich <jbeich@FreeBSD.org>2015-11-15 03:34:12 +0800
commit584ca3787542b6e3bc7e468000628f098e0bbfc4 (patch)
treee7641fb657d8e201903d023988865a1bd3fff335 /multimedia/ffmpeg0
parent2f77d326b22b2244f6df23f58eb65567e4ae7816 (diff)
downloadfreebsd-ports-gnome-584ca3787542b6e3bc7e468000628f098e0bbfc4.tar.gz
freebsd-ports-gnome-584ca3787542b6e3bc7e468000628f098e0bbfc4.tar.zst
freebsd-ports-gnome-584ca3787542b6e3bc7e468000628f098e0bbfc4.zip
multimedia/libvpx: update 1.5.0
ABI isn't compatible, so bump PORTREVISION in consumers. Changes: https://chromium.googlesource.com/webm/libvpx/+log/e67d45d..v1.5.0 ACC report: https://people.freebsd.org/~jbeich/compat_reports/libvpx/1.4.0.488_1_to_1.5.0/compat_report.html PR: 204478 Exp-run by: antoine Approved by: ashish (maintainer)
Diffstat (limited to 'multimedia/ffmpeg0')
-rw-r--r--multimedia/ffmpeg0/Makefile1
-rw-r--r--multimedia/ffmpeg0/files/patch-libavcodec-libvpxenc.c39
2 files changed, 40 insertions, 0 deletions
diff --git a/multimedia/ffmpeg0/Makefile b/multimedia/ffmpeg0/Makefile
index dc5317e3f963..3903e75a9f02 100644
--- a/multimedia/ffmpeg0/Makefile
+++ b/multimedia/ffmpeg0/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.7.17
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://ffmpeg.org/releases/
diff --git a/multimedia/ffmpeg0/files/patch-libavcodec-libvpxenc.c b/multimedia/ffmpeg0/files/patch-libavcodec-libvpxenc.c
new file mode 100644
index 000000000000..26cc58e21418
--- /dev/null
+++ b/multimedia/ffmpeg0/files/patch-libavcodec-libvpxenc.c
@@ -0,0 +1,39 @@
+commit 6540fe0
+Author: James Zern <jzern@google.com>
+Date: Mon Oct 19 22:44:11 2015 -0700
+
+ libvpxenc: remove some unused ctrl id mappings
+
+ VP8E_UPD_ENTROPY, VP8E_UPD_REFERENCE, VP8E_USE_REFERENCE were removed
+ from libvpx and the remaining values were never used here
+
+ Reviewed-by: Michael Niedermayer <michael@niedermayer.cc>
+ Signed-off-by: James Zern <jzern@google.com>
+---
+ libavcodec/libvpxenc.c | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git libavcodec/libvpxenc.c libavcodec/libvpxenc.c
+index 5f39783..992122c 100644
+--- libavcodec/libvpxenc.c
++++ libavcodec/libvpxenc.c
+@@ -104,19 +104,11 @@ typedef struct VP8EncoderContext {
+
+ /** String mappings for enum vp8e_enc_control_id */
+ static const char *ctlidstr[] = {
+- [VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
+- [VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
+- [VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
+- [VP8E_SET_ROI_MAP] = "VP8E_SET_ROI_MAP",
+- [VP8E_SET_ACTIVEMAP] = "VP8E_SET_ACTIVEMAP",
+- [VP8E_SET_SCALEMODE] = "VP8E_SET_SCALEMODE",
+ [VP8E_SET_CPUUSED] = "VP8E_SET_CPUUSED",
+ [VP8E_SET_ENABLEAUTOALTREF] = "VP8E_SET_ENABLEAUTOALTREF",
+ [VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
+- [VP8E_SET_SHARPNESS] = "VP8E_SET_SHARPNESS",
+ [VP8E_SET_STATIC_THRESHOLD] = "VP8E_SET_STATIC_THRESHOLD",
+ [VP8E_SET_TOKEN_PARTITIONS] = "VP8E_SET_TOKEN_PARTITIONS",
+- [VP8E_GET_LAST_QUANTIZER] = "VP8E_GET_LAST_QUANTIZER",
+ [VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
+ [VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
+ [VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",