aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ffmpegthumbnailer
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-01-30 04:43:01 +0800
committerriggs <riggs@FreeBSD.org>2014-01-30 04:43:01 +0800
commit52ccf96e04afaf41dc52da7e2ce5cf3edad3a4b3 (patch)
tree720cde80c89049f0ee92deec0b7b82a7f9575a45 /multimedia/ffmpegthumbnailer
parent5e4b14a7ba2a8892d2862f77de0a576273d90cd8 (diff)
downloadfreebsd-ports-gnome-52ccf96e04afaf41dc52da7e2ce5cf3edad3a4b3.tar.gz
freebsd-ports-gnome-52ccf96e04afaf41dc52da7e2ce5cf3edad3a4b3.tar.zst
freebsd-ports-gnome-52ccf96e04afaf41dc52da7e2ce5cf3edad3a4b3.zip
- Support for the MATE desktop environment support
- Add license - Add gconf dirs to pkg-plist - Add MATE_DESC to Mk/bsd.options.desc.mk PR: ports/184462 Submitted by: clutton <clutton@zoho.com> (maintainer) Approved by: thierry (mentor)
Diffstat (limited to 'multimedia/ffmpegthumbnailer')
-rw-r--r--multimedia/ffmpegthumbnailer/Makefile7
-rw-r--r--multimedia/ffmpegthumbnailer/files/patch-dist_ffmpegthumbnailer.thumbnailer8
-rw-r--r--multimedia/ffmpegthumbnailer/pkg-plist4
3 files changed, 18 insertions, 1 deletions
diff --git a/multimedia/ffmpegthumbnailer/Makefile b/multimedia/ffmpegthumbnailer/Makefile
index de52de49d31a..f09a65a38760 100644
--- a/multimedia/ffmpegthumbnailer/Makefile
+++ b/multimedia/ffmpegthumbnailer/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= clutton@zoho.com
COMMENT= Lightweight video thumbnailer that can be used by file managers
+LICENSE= GPLv2 # (or later)
+
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libswscale.so:${PORTSDIR}/multimedia/ffmpeg \
libjpeg.so:${PORTSDIR}/graphics/jpeg
@@ -23,7 +25,10 @@ USES= pathfix pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
-OPTIONS_DEFINE= GNOME
+OPTIONS_DEFINE= GNOME MATE
+OPTIONS_SUB= yes
+
+MATE_CONFIGURE_ENABLE= thumbnailer
.include <bsd.port.options.mk>
diff --git a/multimedia/ffmpegthumbnailer/files/patch-dist_ffmpegthumbnailer.thumbnailer b/multimedia/ffmpegthumbnailer/files/patch-dist_ffmpegthumbnailer.thumbnailer
new file mode 100644
index 000000000000..bbf8e8d0fc4f
--- /dev/null
+++ b/multimedia/ffmpegthumbnailer/files/patch-dist_ffmpegthumbnailer.thumbnailer
@@ -0,0 +1,8 @@
+--- dist/ffmpegthumbnailer.thumbnailer 2012-08-25 15:32:20.000000000 +0300
++++ dist/ffmpegthumbnailer.thumbnailer 2013-12-03 05:21:35.000000000 +0200
+@@ -1,4 +1,4 @@
+ [Thumbnailer Entry]
+ TryExec=ffmpegthumbnailer
+ Exec=ffmpegthumbnailer -i %i -o %o -s %s -f
+-MimeType=video/jpeg;video/mp4;video/mpeg;video/quicktime;video/x-ms-asf;video/x-ms-wm;video/x-ms-wmv;video/x-msvideo;video/x-flv;video/x-matroska;
++MimeType=application/mxf;application/ogg;application/ram;application/sdp;application/vnd.ms-wpl;application/vnd.rn-realmedia;application/x-extension-m4a;application/x-extension-mp4;application/x-flash-video;application/x-matroska;application/x-netshow-channel;application/x-ogg;application/x-quicktimeplayer;application/x-shorten;image/vnd.rn-realpix;image/x-pict;misc/ultravox;text/x-google-video-pointer;video/3gpp;video/dv;video/fli;video/flv;video/jpeg;video/mp2t;video/mp4;video/mp4v-es;video/mpeg;video/msvideo;video/ogg;video/quicktime;video/vivo;video/vnd.divx;video/vnd.rn-realvideo;video/vnd.vivo;video/webm;video/x-anim;video/x-avi;video/x-flc;video/x-fli;video/x-flic;video/x-flv;video/x-m4v;video/x-matroska;video/x-mpeg;video/x-ms-asf;video/x-ms-asx;video/x-msvideo;video/x-ms-wm;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvx;video/x-nsv;video/x-ogm+ogg;video/x-theora+ogg;video/x-totem-stream;audio/x-pn-realaudio;audio/3gpp;audio/ac3;audio/AMR;audio/AMR-WB;audio/basic;audio/midi;a
diff --git a/multimedia/ffmpegthumbnailer/pkg-plist b/multimedia/ffmpegthumbnailer/pkg-plist
index 0d043b283a69..e58981c5bc55 100644
--- a/multimedia/ffmpegthumbnailer/pkg-plist
+++ b/multimedia/ffmpegthumbnailer/pkg-plist
@@ -1,4 +1,6 @@
bin/ffmpegthumbnailer
+%%GNOME%%@dirrmtry etc/gconf/gconf.xml.defaults
+%%GNOME%%@dirrmtry etc/gconf/schemas
include/libffmpegthumbnailer/filmstripfilter.h
include/libffmpegthumbnailer/ifilter.h
include/libffmpegthumbnailer/imagetypes.h
@@ -11,4 +13,6 @@ lib/libffmpegthumbnailer.so
lib/libffmpegthumbnailer.so.4
libdata/pkgconfig/libffmpegthumbnailer.pc
man/man1/ffmpegthumbnailer.1.gz
+%%MATE%%share/thumbnailers/ffmpegthumbnailer.thumbnailer
+%%MATE%%@dirrmtry share/thumbnailers
@dirrm include/libffmpegthumbnailer