aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gmencoder/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-25 18:22:27 +0800
committerkrion <krion@FreeBSD.org>2004-02-25 18:22:27 +0800
commit25a7a6ac28c5c99fc2941613667d4c5af069a6e1 (patch)
tree700dfcfac668915174a49869e6ea4e52172cbb27 /multimedia/gmencoder/Makefile
parent4197a07893b3c2c7e3fbdb9129f9bef6451677af (diff)
downloadfreebsd-ports-gnome-25a7a6ac28c5c99fc2941613667d4c5af069a6e1.tar.gz
freebsd-ports-gnome-25a7a6ac28c5c99fc2941613667d4c5af069a6e1.tar.zst
freebsd-ports-gnome-25a7a6ac28c5c99fc2941613667d4c5af069a6e1.zip
Add gmencoder 0.1.0,
Gmencoder is Gnome2 front-end to mplayer/mencoder. It supports mamy of the output codecs as well as postprocesing, cropping, scale, subtitles ripping, 1, 2 and 3 passes for encoding. PR: ports/63337 Submitted by: Michael Johnson <ahze@ahze.net>
Diffstat (limited to 'multimedia/gmencoder/Makefile')
-rw-r--r--multimedia/gmencoder/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/multimedia/gmencoder/Makefile b/multimedia/gmencoder/Makefile
new file mode 100644
index 000000000000..11e1a497d68d
--- /dev/null
+++ b/multimedia/gmencoder/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: gmencoder
+# Date created: Wed Feb 25 03:20:50 EST 2004
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmencoder
+PORTVERSION= 0.1.0
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Gmencoder is Gnome2 front-end to mplayer/mencoder
+
+BUILD_DEPENDS= mencoder:${PORTSDIR}/multimedia/mplayer
+RUN_DEPENDS= mencoder:${PORTSDIR}/multimedia/mplayer
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SH} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} ${CONFIGURE_ENV}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>