aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gmencoder/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-03-06 04:56:40 +0800
committeradamw <adamw@FreeBSD.org>2004-03-06 04:56:40 +0800
commit61f1f02f86f33bd9c40c2d31cf5a02cd747ef91f (patch)
tree7a87d0df788153d6c21944e63e900052966965fb /multimedia/gmencoder/Makefile
parentcc155d8f3fcde3cb9d96219a73c6972f098f78e3 (diff)
downloadfreebsd-ports-gnome-61f1f02f86f33bd9c40c2d31cf5a02cd747ef91f.tar.gz
freebsd-ports-gnome-61f1f02f86f33bd9c40c2d31cf5a02cd747ef91f.tar.zst
freebsd-ports-gnome-61f1f02f86f33bd9c40c2d31cf5a02cd747ef91f.zip
Fix build, use GNU_CONFIGURE instead of HAS_CONFIGURE and a
wacky do-configure target, and change the pkg-plist to add missing files. PORTREVISION bump cuz of that last change.
Diffstat (limited to 'multimedia/gmencoder/Makefile')
-rw-r--r--multimedia/gmencoder/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/multimedia/gmencoder/Makefile b/multimedia/gmencoder/Makefile
index 11e1a497d68d..ad06294f0f57 100644
--- a/multimedia/gmencoder/Makefile
+++ b/multimedia/gmencoder/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmencoder
PORTVERSION= 0.1.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +19,7 @@ COMMENT= Gmencoder is Gnome2 front-end to mplayer/mencoder
BUILD_DEPENDS= mencoder:${PORTSDIR}/multimedia/mplayer
RUN_DEPENDS= mencoder:${PORTSDIR}/multimedia/mplayer
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
@@ -26,11 +27,8 @@ USE_GNOME= gnomehack gnomeprefix libgnomeui
USE_REINPLACE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
-
-do-configure:
- @cd ${WRKSRC}; \
- ${SH} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} ${CONFIGURE_ENV}
+ @${REINPLACE_CMD} -e 's|-O4||; s|type -path|which|' \
+ ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)