aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-player
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-02-18 11:50:38 +0800
committeradamw <adamw@FreeBSD.org>2004-02-18 11:50:38 +0800
commitd54a3b0f1a738ab689824d255aa5acf2e0fe3e42 (patch)
treee54f44a172651f143d14bb72b8c2b5ba71f59cdb /multimedia/gstreamer-player
parent85c8f3f941efa685ff55da9ec788c7db82afee6f (diff)
downloadfreebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.tar.gz
freebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.tar.zst
freebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.zip
GTK2 mozilla is now the default, and GTK1 support will be built only if explicitly
requested. This means that mozilla-gtk2 and mozilla-devel-gtk2 are now mozilla and mozilla-devel, respectively; and the old mozilla and mozilla-devel are now mozilla-gtk1 and mozilla-devel-gtk1. This is done for a whole plethora of reasons, and should please everybody except galeon1 fanatics and uhm... anybody else who it doesn't please. If you have WITH_MOZILLA set in your /etc/make.conf, you'll need to update the value accordingly. GTK2 ports will automatically install GTK2 mozilla, and GTK1 ports will automatically install GTK1 ports, so WITH_MOZILLA need be defined only if you want the development version... which are dormant right now anyway. For now, all ports that honoured WITH_MOZILLA=mozilla-{,-devel}-gtk2 will still honour those values as well as WITH_MOZILLA=mozilla{,-devel}, but future ports reserve the right to ignore the *-gtk2 values.
Diffstat (limited to 'multimedia/gstreamer-player')
-rw-r--r--multimedia/gstreamer-player/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/multimedia/gstreamer-player/Makefile b/multimedia/gstreamer-player/Makefile
index c69422b43428..4b3c122061c3 100644
--- a/multimedia/gstreamer-player/Makefile
+++ b/multimedia/gstreamer-player/Makefile
@@ -47,18 +47,17 @@ pre-install:
@${MKDIR} ${PREFIX}/etc/gconf/
.if defined(WITH_MOZILLA_PLUGIN)
-BUILD_DEPENDS+= ${X11BASE}/include/mozilla${HEADERS_SUFX}/plugin/npapi.h:${PORTSDIR}/www/mozilla-headers${HEADERS_SUFX} \
- ${X11BASE}/lib/${MOZILLA}/mozilla-config:${PORTSDIR}/www/${MOZILLA}
+BUILD_DEPENDS+= ${X11BASE}/lib/${MOZILLA}/mozilla-config:${PORTSDIR}/www/${MOZILLA}
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
.else
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.endif
.endif