aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
committeredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
commit5d87bf6f020ae3177a26e679d65b5e50f035bbe1 (patch)
treeca9d8a7830bc4c19ec29804b066fc99d81d7488b /multimedia/gstreamer-plugins
parent476102ca837a76b18c930b013cb486ec3f0ce79e (diff)
downloadfreebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.gz
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.zst
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 3a41d7ca36db..7153c000d7b4 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -32,6 +32,7 @@ USE_GNOME= gnomehack \
USE_LIBTOOL= yes
USE_REINPLACE= yes
USE_SIZE= yes
+WANT_SDL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-tests \
--disable-alsa \
@@ -56,7 +57,6 @@ WANT_GNOME= yes
MAN1= gst-launch-ext.1 gst-visualise.1
PKG_CONFIG?="${LOCALBASE}/bin/pkg-config"
-SDL_CONFIG?="${LOCALBASE}/bin/sdl11-config"
XMMS_CONFIG?="${LOCALBASE}/bin/xmms-config"
# library minor number
@@ -258,7 +258,7 @@ WITH_PNG=yes
.endif
# sdl
-.if exists(${LOCALBASE}/lib/libSDL-1.1.a)
+.if ${HAVE_SDL:Msdl}
WITH_SDL=yes
.endif
@@ -582,11 +582,9 @@ CONFIGURE_ARGS+= --disable-sdl \
--disable-sdltest
PLIST_SUB+= SDL="@comment "
.else
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
CONFIGURE_ARGS+= --with-sdl-prefix=${LOCALBASE} \
--with-sdl-exec-prefix=${LOCALBASE}
-CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
PLIST_SUB+= SDL=""
.endif