aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-qt4
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
committertcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
commita5fddeafcdb2cab1016827038e317a262dad4857 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /multimedia/gstreamer-qt4
parent3832b190ef3ea2bbefdd61450bff8af422a2e9ae (diff)
downloadfreebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.gz
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.zst
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'multimedia/gstreamer-qt4')
-rw-r--r--multimedia/gstreamer-qt4/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/gstreamer-qt4/Makefile b/multimedia/gstreamer-qt4/Makefile
index f7d29725d7a8..0334472d7b38 100644
--- a/multimedia/gstreamer-qt4/Makefile
+++ b/multimedia/gstreamer-qt4/Makefile
@@ -17,11 +17,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-USES= bison cmake gmake pkgconfig tar:bzip2
+USES= bison cmake gmake kde:4 pkgconfig tar:bzip2
USE_LDCONFIG= yes
USE_GSTREAMER= yes
USE_GNOME= glib20
-USE_KDE4= automoc4
+USE_KDE= automoc4
USE_QT4= corelib gui opengl declarative \
qmake_build moc_build rcc_build uic_build qtestlib_build