aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer1-plugins-core
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-04-28 04:56:38 +0800
committerKoop Mast <kwm@FreeBSD.org>2013-04-28 04:56:38 +0800
commit05d2886d27cb71e18dd917003926e7a165f40fa1 (patch)
treef41470c54496d3f979b6727ed30042270de45c74 /multimedia/gstreamer1-plugins-core
parentf52d0a56a81ecf2c86d06a719ee9cb91b7d5d005 (diff)
downloadfreebsd-ports-gnome-05d2886d27cb71e18dd917003926e7a165f40fa1.tar.gz
freebsd-ports-gnome-05d2886d27cb71e18dd917003926e7a165f40fa1.tar.zst
freebsd-ports-gnome-05d2886d27cb71e18dd917003926e7a165f40fa1.zip
Add Gstreamer 1.0.7. This is the new stable version of the
Gstreamer multimedia framework. Use the USE_GSTREAMER1 macro to select Gstreamer 1.0 plugins. A new chapter for the porters handbook about gstreamer is a work in progress. X related plugins are now stand alone. The gio plugin is now part of the gstreamer1-plugins port and the oss plugins are now part of the gstreamer1-plugins-good port. Note that the pulseaudio plugin is missing because it needs a newer version of pulseaudio. Also there are still a number of plugins from -bad which haven't been ported to the 1.0 API yet.
Diffstat (limited to 'multimedia/gstreamer1-plugins-core')
-rw-r--r--multimedia/gstreamer1-plugins-core/Makefile51
-rw-r--r--multimedia/gstreamer1-plugins-core/pkg-descr3
2 files changed, 54 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-plugins-core/Makefile b/multimedia/gstreamer1-plugins-core/Makefile
new file mode 100644
index 000000000000..e43bd240554d
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-core/Makefile
@@ -0,0 +1,51 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer-plugins-core/Makefile,v 1.17 2006/07/17 01:39:57 ahze Exp $
+
+PORTNAME= gstreamer-plugins-core
+PORTVERSION= ${GST1_VERSION}
+PORTREVISION= 0
+CATEGORIES= multimedia audio
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= Core set of typical audio and video gstreamer-plugins
+
+NO_BUILD= yes
+GST_DIR= lib/gstreamer-${PORTVERSION}
+PLIST_FILES= ${GST_DIR}/.gstreamer-plugins-core.keep
+
+USE_GSTREAMER1=yes
+
+OPTIONS_DEFINE= DVD
+OPTIONS_DEFAULT=DVD
+DVD_DESC= Include DVD related plugins
+
+.include <bsd.port.options.mk>
+
+# Audio plugins
+USE_GSTREAMER1+= mad ogg vorbis
+
+# Graphics plugins
+USE_GSTREAMER1+= png
+
+# Misc plugins
+USE_GSTREAMER1+= pango
+
+# Multimedia plugins
+USE_GSTREAMER1+= libav good theora
+
+.if ${PORT_OPTIONS:MDVD}
+# dvd related plugins plugins
+USE_GSTREAMER1+= a52dec dvdread resindvd dts
+.endif
+
+do-install:
+ if [ ! -d ${PREFIX}/${GST_DIR} ]; then \
+ ${MKDIR} ${PREFIX}/${GST_DIR} ; \
+ fi
+ ${TOUCH} -f ${PREFIX}/${GST_DIR}/.gstreamer-plugins-core.keep
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-plugins-core/pkg-descr b/multimedia/gstreamer1-plugins-core/pkg-descr
new file mode 100644
index 000000000000..90895a218dc8
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-core/pkg-descr
@@ -0,0 +1,3 @@
+Meta-port to core "typical" gstreamer-plugins
+
+WWW: http://gstreamer.net