aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
committermarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
commit7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3 (patch)
tree862f96db414616c771eb64412d27d795591004f0 /multimedia/gstreamer
parent6c3349d5db64bb9ea320c30d23ba353e2f013754 (diff)
downloadfreebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.gz
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.zst
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Diffstat (limited to 'multimedia/gstreamer')
-rw-r--r--multimedia/gstreamer/Makefile20
-rw-r--r--multimedia/gstreamer/distinfo6
-rw-r--r--multimedia/gstreamer/pkg-plist13
3 files changed, 29 insertions, 10 deletions
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index 64969c21a115..f4152e378d9b 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -3,11 +3,11 @@
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/multimedia/gstreamer/Makefile,v 1.1 2007/12/02 16:39:58 ahze Exp $
+# $MCom: ports/multimedia/gstreamer/Makefile,v 1.59 2008/03/21 03:53:00 ahze Exp $
#
PORTNAME= gstreamer
-PORTVERSION= 0.10.15
+PORTVERSION= 0.10.18
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/gstreamer/ \
${MASTER_SITE_LOCAL}
@@ -19,12 +19,12 @@ COMMENT= Development framework for creating media applications
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
CFLAGS:= ${CFLAGS} -O2
-USE_XLIB= yes
USE_BISON= build
+USE_XORG= x11 xv xext videoproto xextproto
USE_BZIP2= yes
USE_GMAKE= yes
WANT_GNOME= yes
-USE_GNOME= gnomehack glib20 libxml2 ltverhack
+USE_GNOME= gnomehack glib20 libxml2 ltverhack ltasneededhack
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --disable-tests \
@@ -44,4 +44,14 @@ MAN1= gst-feedback-${GST_VERSION}.1 gst-inspect-${GST_VERSION}.1 \
gst-typefind-${GST_VERSION}.1 gst-xmlinspect-${GST_VERSION}.1 \
gst-xmllaunch-${GST_VERSION}.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if (exists(${LOCALBASE}/lib/libcheck.a) || defined(WITH_CHECK))
+LIB_DEPENDS+= check.0:${PORTSDIR}/devel/libcheck
+PLIST_SUB+= CHECK=""
+.else
+CONFIGURE_ARGS+=--without-check
+PLIST_SUB+= CHECK="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer/distinfo b/multimedia/gstreamer/distinfo
index bc1ab4a6dc29..2fc189436e8e 100644
--- a/multimedia/gstreamer/distinfo
+++ b/multimedia/gstreamer/distinfo
@@ -1,3 +1,3 @@
-MD5 (gstreamer-0.10.15.tar.bz2) = 09f1c4ea025faef88b566fa26ec24ae0
-SHA256 (gstreamer-0.10.15.tar.bz2) = 581bc480fadeace5be05291dae634065e56986d13037fbcee0ba126cb9435abb
-SIZE (gstreamer-0.10.15.tar.bz2) = 2158226
+MD5 (gstreamer-0.10.18.tar.bz2) = 3b2f9b2b50f7265bbaac8ea10a8279b8
+SHA256 (gstreamer-0.10.18.tar.bz2) = c07249bb07cf3be4c6c83c0f2cc65f8d9d163777d873d142e84e57645435fb5d
+SIZE (gstreamer-0.10.18.tar.bz2) = 2221787
diff --git a/multimedia/gstreamer/pkg-plist b/multimedia/gstreamer/pkg-plist
index 95f5d7ef3653..915cc9b2c609 100644
--- a/multimedia/gstreamer/pkg-plist
+++ b/multimedia/gstreamer/pkg-plist
@@ -16,8 +16,11 @@ include/gstreamer-%%VERSION%%/gst/base/gstbasesrc.h
include/gstreamer-%%VERSION%%/gst/base/gstbasetransform.h
include/gstreamer-%%VERSION%%/gst/base/gstcollectpads.h
include/gstreamer-%%VERSION%%/gst/base/gstdataqueue.h
+include/gstreamer-%%VERSION%%/gst/gstpoll.h
include/gstreamer-%%VERSION%%/gst/base/gstpushsrc.h
include/gstreamer-%%VERSION%%/gst/base/gsttypefindhelper.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstbufferstraw.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstcheck.h
include/gstreamer-%%VERSION%%/gst/controller/gstcontroller.h
include/gstreamer-%%VERSION%%/gst/controller/gstcontrolsource.h
include/gstreamer-%%VERSION%%/gst/controller/gstinterpolationcontrolsource.h
@@ -89,6 +92,10 @@ lib/libgstbase-%%VERSION%%.a
lib/libgstbase-%%VERSION%%.la
lib/libgstbase-%%VERSION%%.so
lib/libgstbase-%%VERSION%%.so.0
+%%CHECK%%lib/libgstcheck-%%VERSION%%.a
+%%CHECK%%lib/libgstcheck-%%VERSION%%.la
+%%CHECK%%lib/libgstcheck-%%VERSION%%.so
+%%CHECK%%lib/libgstcheck-%%VERSION%%.so.0
lib/libgstcontroller-%%VERSION%%.a
lib/libgstcontroller-%%VERSION%%.la
lib/libgstcontroller-%%VERSION%%.so
@@ -107,6 +114,7 @@ lib/libgstreamer-%%VERSION%%.so
lib/libgstreamer-%%VERSION%%.so.0
libdata/pkgconfig/gstreamer-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-base-%%VERSION%%.pc
+%%CHECK%%libdata/pkgconfig/gstreamer-check-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-controller-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-dataprotocol-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-net-%%VERSION%%.pc
@@ -139,12 +147,13 @@ share/locale/uk/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/vi/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/zh_CN/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/zh_TW/LC_MESSAGES/gstreamer-%%VERSION%%.mo
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
@dirrm lib/gstreamer-%%VERSION%%
@dirrm include/gstreamer-%%VERSION%%/gst/net
@dirrm include/gstreamer-%%VERSION%%/gst/dataprotocol
@dirrm include/gstreamer-%%VERSION%%/gst/controller
+%%CHECK%%@dirrm include/gstreamer-%%VERSION%%/gst/check
@dirrm include/gstreamer-%%VERSION%%/gst/base
@dirrm include/gstreamer-%%VERSION%%/gst
@dirrm include/gstreamer-%%VERSION%%
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw