aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gxine
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-08-29 06:51:24 +0800
committerpav <pav@FreeBSD.org>2006-08-29 06:51:24 +0800
commita7cefef647c947f2191502b216410221ee56692f (patch)
tree4518971fadaeb031167aef248b39d61a743ca44c /multimedia/gxine
parent04be59c6f546b73d7f78bdd0a86b693f7345602d (diff)
downloadfreebsd-ports-gnome-a7cefef647c947f2191502b216410221ee56692f.tar.gz
freebsd-ports-gnome-a7cefef647c947f2191502b216410221ee56692f.tar.zst
freebsd-ports-gnome-a7cefef647c947f2191502b216410221ee56692f.zip
- Update to 0.5.7
- Provide WITHOUT_NLS knob PR: ports/101530 Submitted by: Max Brazhnikov <makc@issp.ac.ru> Approved by: maintainer timeout (1 and half month)
Diffstat (limited to 'multimedia/gxine')
-rw-r--r--multimedia/gxine/Makefile24
-rw-r--r--multimedia/gxine/distinfo6
-rw-r--r--multimedia/gxine/files/patch-browser-plugin::plugin.c10
-rw-r--r--multimedia/gxine/files/patch-src::desktop_integration.c10
-rw-r--r--multimedia/gxine/files/patch-src::engine.c11
-rw-r--r--multimedia/gxine/files/patch-src::globals.h10
-rw-r--r--multimedia/gxine/files/patch-src::gtkxine.h10
-rw-r--r--multimedia/gxine/files/patch-src::http.c8
-rw-r--r--multimedia/gxine/files/patch-src::script_engine.c11
-rw-r--r--multimedia/gxine/files/patch-src::spidermonkey::jsprf.c16
-rw-r--r--multimedia/gxine/pkg-plist49
11 files changed, 95 insertions, 70 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index 72a6737775d4..5366759b5176 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -6,33 +6,49 @@
#
PORTNAME= gxine
-PORTVERSION= 0.3.3
-PORTREVISION= 16
+PORTVERSION= 0.5.7
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xine
-MAINTAINER= greg@chown.ath.cx
+MAINTAINER= makc@issp.ac.ru
COMMENT= An alternative GUI for the Xine media player
LIB_DEPENDS= xine.15:${PORTSDIR}/multimedia/libxine
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= gtk20 gnomehier
+USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -I${X11BASE}/lib"
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
+INSTALLS_ICONS= yes
MANLANG= "" de
-MAN1= gxine.1
+MAN1= gxine.1 gxine_client.1
+MANCOMPRESSED= no
OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" on
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
.if defined(WITHOUT_MOZILLA_PLUGIN)
+LIB_DEPENDS+= js.1:${PORTSDIR}/lang/spidermonkey
+CONFIGURE_ARGS+=--without-browser-plugin
PLIST_SUB+= MOZILLA_PLUGIN="@comment "
.else
+USE_GECKO= firefox mozilla seamonkey xulrunner firefox-devel
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+CONFIGURE_ARGS+=--disable-libjs
PLIST_SUB+= MOZILLA_PLUGIN=""
.endif
diff --git a/multimedia/gxine/distinfo b/multimedia/gxine/distinfo
index 0ad5f90340ff..15ef793d9217 100644
--- a/multimedia/gxine/distinfo
+++ b/multimedia/gxine/distinfo
@@ -1,3 +1,3 @@
-MD5 (gxine-0.3.3.tar.gz) = d54af2f901065555348a77fa3b61581e
-SHA256 (gxine-0.3.3.tar.gz) = 1edc1776001e980ffbadcb66917f144ef2fca8f9eba10e73f6dfc79eaac18110
-SIZE (gxine-0.3.3.tar.gz) = 1038778
+MD5 (gxine-0.5.7.tar.bz2) = 61585b08f699a33528749be101fe8a87
+SHA256 (gxine-0.5.7.tar.bz2) = 08f9da823bf87ce9a7beae6938ab2e5405004bb85f97ba49e3a2a1738ec0520c
+SIZE (gxine-0.5.7.tar.bz2) = 964963
diff --git a/multimedia/gxine/files/patch-browser-plugin::plugin.c b/multimedia/gxine/files/patch-browser-plugin::plugin.c
deleted file mode 100644
index 239576efdc78..000000000000
--- a/multimedia/gxine/files/patch-browser-plugin::plugin.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- browser-plugin/plugin.c.orig Tue May 6 14:20:32 2003
-+++ browser-plugin/plugin.c Tue May 6 14:20:50 2003
-@@ -47,6 +47,7 @@
-
- #include <stdio.h>
- #include <math.h>
-+#include <signal.h>
-
-
-
diff --git a/multimedia/gxine/files/patch-src::desktop_integration.c b/multimedia/gxine/files/patch-src::desktop_integration.c
index d37f38199edf..e1cd4c4b2442 100644
--- a/multimedia/gxine/files/patch-src::desktop_integration.c
+++ b/multimedia/gxine/files/patch-src::desktop_integration.c
@@ -1,10 +1,10 @@
---- src/desktop_integration.c.orig Sat Apr 19 02:23:31 2003
-+++ src/desktop_integration.c Sat Apr 19 02:23:39 2003
-@@ -30,7 +30,6 @@
+--- src/desktop_integration.c.orig Thu Jun 8 18:15:59 2006
++++ src/desktop_integration.c Tue Jul 11 00:35:11 2006
+@@ -31,7 +31,6 @@
#include <stdlib.h>
#include <stdio.h>
#include <dlfcn.h>
-#include <alloca.h>
#include <string.h>
-
- #include "globals.h"
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/multimedia/gxine/files/patch-src::engine.c b/multimedia/gxine/files/patch-src::engine.c
new file mode 100644
index 000000000000..b037e81f3569
--- /dev/null
+++ b/multimedia/gxine/files/patch-src::engine.c
@@ -0,0 +1,11 @@
+--- src/engine.c.orig Fri Jun 30 18:56:00 2006
++++ src/engine.c Tue Jul 11 01:36:59 2006
+@@ -36,7 +36,7 @@
+
+ se_t *gse; /* global script engine */
+ xine_t *xine; /* global xine instance */
+-pthread_mutex_t engine_lock = PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
++pthread_mutex_t engine_lock = PTHREAD_MUTEX_INITIALIZER;
+
+ gboolean initialised = FALSE;
+
diff --git a/multimedia/gxine/files/patch-src::globals.h b/multimedia/gxine/files/patch-src::globals.h
deleted file mode 100644
index a64fb759e2de..000000000000
--- a/multimedia/gxine/files/patch-src::globals.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/globals.h.orig Sat Apr 19 02:18:27 2003
-+++ src/globals.h Sat Apr 19 02:20:42 2003
-@@ -28,6 +28,7 @@
- #include <gtk/gtk.h>
- #include <gdk/gdk.h>
- #include <glib.h>
-+#include <pthread.h>
-
- #include "infobar.h"
-
diff --git a/multimedia/gxine/files/patch-src::gtkxine.h b/multimedia/gxine/files/patch-src::gtkxine.h
deleted file mode 100644
index 8d486b8e7ee0..000000000000
--- a/multimedia/gxine/files/patch-src::gtkxine.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/gtkxine.h.orig Sat Apr 19 02:24:55 2003
-+++ src/gtkxine.h Sat Apr 19 02:25:07 2003
-@@ -27,6 +27,7 @@
- #include <X11/Xlib.h>
- #include <X11/extensions/XShm.h>
- #include <xine.h>
-+#include "globals.h"
-
- #ifdef __cplusplus
- extern "C" {
diff --git a/multimedia/gxine/files/patch-src::http.c b/multimedia/gxine/files/patch-src::http.c
index a31b59bc3bb0..1d51c029379f 100644
--- a/multimedia/gxine/files/patch-src::http.c
+++ b/multimedia/gxine/files/patch-src::http.c
@@ -1,12 +1,12 @@
---- src/http.c.orig Sat Apr 19 02:22:23 2003
-+++ src/http.c Sat Apr 19 02:22:34 2003
+--- src/http.c.orig Thu Jun 29 04:35:39 2006
++++ src/http.c Tue Jul 11 00:54:35 2006
@@ -35,6 +35,9 @@
- #include <unistd.h>
#include <ctype.h>
#include <errno.h>
+
+#include <netinet/in.h>
+#include <arpa/inet.h>
+#define IPPROTO_TCP 6
-
#include "http.h"
+ #include "utils.h"
diff --git a/multimedia/gxine/files/patch-src::script_engine.c b/multimedia/gxine/files/patch-src::script_engine.c
new file mode 100644
index 000000000000..ef082b66462c
--- /dev/null
+++ b/multimedia/gxine/files/patch-src::script_engine.c
@@ -0,0 +1,11 @@
+--- src/script_engine.c.orig Thu Jun 15 17:13:25 2006
++++ src/script_engine.c Tue Jul 11 00:38:49 2006
+@@ -1554,7 +1554,7 @@
+
+ pthread_mutexattr_t attr;
+ pthread_mutexattr_init (&attr);
+- pthread_mutexattr_settype (&attr, PTHREAD_MUTEX_RECURSIVE_NP);
++ pthread_mutexattr_settype (&attr, PTHREAD_MUTEX_RECURSIVE);
+ pthread_mutex_init (&se->lock, &attr);
+ pthread_mutexattr_destroy (&attr);
+
diff --git a/multimedia/gxine/files/patch-src::spidermonkey::jsprf.c b/multimedia/gxine/files/patch-src::spidermonkey::jsprf.c
deleted file mode 100644
index aa72af7ae80b..000000000000
--- a/multimedia/gxine/files/patch-src::spidermonkey::jsprf.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/spidermonkey/jsprf.c.orig Fri Mar 7 02:14:11 2003
-+++ src/spidermonkey/jsprf.c Wed Sep 21 20:20:45 2005
-@@ -57,7 +57,12 @@
- #define VARARGS_ASSIGN(foo, bar) (foo) = (bar)
- #endif
- */
--#define VARARGS_ASSIGN(foo, bar) __va_copy(foo, bar)
-+#include <osreldate.h>
-+#if __FreeBSD_version >= 500000
-+#define VARARGS_ASSIGN(foo, bar) va_copy(foo, bar)
-+#else
-+#define VARARGS_ASSIGN(foo, bar) (foo) = (bar)
-+#endif
-
- /*
- ** WARNING: This code may *NOT* call JS_LOG (because JS_LOG calls it)
diff --git a/multimedia/gxine/pkg-plist b/multimedia/gxine/pkg-plist
index c1712792a611..cc9f77f928e6 100644
--- a/multimedia/gxine/pkg-plist
+++ b/multimedia/gxine/pkg-plist
@@ -1,17 +1,50 @@
bin/gxine
bin/gxine_client
+etc/gxine/gtkrc
+etc/gxine/keypad.xml
+etc/gxine/startup
+etc/gxine/toolbar-fullscreen.xml
+etc/gxine/toolbar-window.xml
+%%MOZILLA_PLUGIN%%lib/browser_plugins/gxineplugin.so
+%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.a
+%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.la
+%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.so
+share/applications/gxine.desktop
%%DATADIR%%/logo.mpv
-%%DATADIR%%/pixmaps/gxine-logo.png
+%%DATADIR%%/mediamarks
%%DATADIR%%/pixmaps/gxine-icon.xpm
-%%DATADIR%%/pixmaps/wizards.png
+%%DATADIR%%/pixmaps/nospeaker.png
+%%DATADIR%%/pixmaps/set-brightness.svg
+%%DATADIR%%/pixmaps/set-contrast.svg
+%%DATADIR%%/pixmaps/set-saturation.svg
+%%DATADIR%%/pixmaps/set-volume.svg
+%%DATADIR%%/pixmaps/speaker.png
%%DATADIR%%/pixmaps/splash.png
-%%DATADIR%%/mediamarks
-share/gnome/apps/Multimedia/gxine.desktop
-lib/gxine/gxineplugin.a
-lib/gxine/gxineplugin.la
-lib/gxine/gxineplugin.so
-%%MOZILLA_PLUGIN%%lib/browser_plugins/gxineplugin.so
+share/icons/hicolor/48x48/apps/gxine.png
+%%NLS%%share/locale/cs/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gxine.theme.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gxine.theme.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gxine.theme.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gxine.theme.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gxine.theme.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gxine.theme.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gxine.theme.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/gxine.theme.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gxine.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gxine.theme.mo
+share/pixmaps/gxine.png
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
+@dirrmtry share/applications
+@dirrmtry man/de/man1
+@dirrmtry man/de
@dirrm lib/gxine
%%MOZILLA_PLUGIN%%@dirrmtry lib/browser_plugins
+@dirrm etc/gxine