aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gxine
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-24 06:04:39 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-24 06:04:39 +0800
commitf454592ec1763319eec434d6dc92a0a54735365d (patch)
tree96b0ff84b9caa92eae61db87ae0fe1a6fc214f6f /multimedia/gxine
parent4326fc427a0bdfb57d894895ae222e7d6bcc546e (diff)
downloadfreebsd-ports-gnome-f454592ec1763319eec434d6dc92a0a54735365d.tar.gz
freebsd-ports-gnome-f454592ec1763319eec434d6dc92a0a54735365d.tar.zst
freebsd-ports-gnome-f454592ec1763319eec434d6dc92a0a54735365d.zip
- Add OPTION to turn off Mozilla/Firefox plugin installation [1]
- Use DATADIR macro in plist [1] - add gnomehier to USE_GNOME to fix deinstallation [2] PR: ports/98507 [1] Submitted by: Kim Scarborough <sluggo@unknown.nu> [1]. itetcu (me) [2] Approved by: maintainer timeout
Diffstat (limited to 'multimedia/gxine')
-rw-r--r--multimedia/gxine/Makefile16
-rw-r--r--multimedia/gxine/pkg-plist22
2 files changed, 24 insertions, 14 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index 879ec638e977..72a6737775d4 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -19,15 +19,27 @@ LIB_DEPENDS= xine.15:${PORTSDIR}/multimedia/libxine
USE_X_PREFIX= yes
USE_AUTOTOOLS= libtool:15
-USE_GNOME= gtk20
+USE_GNOME= gtk20 gnomehier
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -I${X11BASE}/lib"
MANLANG= "" de
MAN1= gxine.1
+OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_MOZILLA_PLUGIN)
+PLIST_SUB+= MOZILLA_PLUGIN="@comment "
+.else
+PLIST_SUB+= MOZILLA_PLUGIN=""
+.endif
+
post-install:
+.if !defined(WITHOUT_MOZILLA_PLUGIN)
@${MKDIR} ${PREFIX}/lib/browser_plugins
@${LN} -sf ${PREFIX}/lib/gxine/gxineplugin.so ${PREFIX}/lib/browser_plugins
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/gxine/pkg-plist b/multimedia/gxine/pkg-plist
index c76ad9a66ab8..c1712792a611 100644
--- a/multimedia/gxine/pkg-plist
+++ b/multimedia/gxine/pkg-plist
@@ -1,19 +1,17 @@
bin/gxine
bin/gxine_client
-share/gxine/logo.mpv
-share/gxine/pixmaps/gxine-logo.png
-share/gxine/pixmaps/gxine-icon.xpm
-share/gxine/pixmaps/wizards.png
-share/gxine/pixmaps/splash.png
-share/gxine/mediamarks
+%%DATADIR%%/logo.mpv
+%%DATADIR%%/pixmaps/gxine-logo.png
+%%DATADIR%%/pixmaps/gxine-icon.xpm
+%%DATADIR%%/pixmaps/wizards.png
+%%DATADIR%%/pixmaps/splash.png
+%%DATADIR%%/mediamarks
share/gnome/apps/Multimedia/gxine.desktop
lib/gxine/gxineplugin.a
lib/gxine/gxineplugin.la
lib/gxine/gxineplugin.so
-lib/browser_plugins/gxineplugin.a
-lib/browser_plugins/gxineplugin.la
-lib/browser_plugins/gxineplugin.so
-@dirrm share/gxine/pixmaps
-@dirrm share/gxine
+%%MOZILLA_PLUGIN%%lib/browser_plugins/gxineplugin.so
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%
@dirrm lib/gxine
-@dirrm lib/browser_plugins
+%%MOZILLA_PLUGIN%%@dirrmtry lib/browser_plugins