aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kdemultimedia4-ffmpegthumbs
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
committermakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
commit4071ff71b938de957201b333e5ab5b90c718c7a6 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /multimedia/kdemultimedia4-ffmpegthumbs
parente847a9821369a4907e8956149272623bd60baa79 (diff)
downloadfreebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.gz
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.zst
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Diffstat (limited to 'multimedia/kdemultimedia4-ffmpegthumbs')
-rw-r--r--multimedia/kdemultimedia4-ffmpegthumbs/Makefile13
-rw-r--r--multimedia/kdemultimedia4-ffmpegthumbs/distinfo4
-rw-r--r--multimedia/kdemultimedia4-ffmpegthumbs/files/patch-CMakeLists.txt20
-rw-r--r--multimedia/kdemultimedia4-ffmpegthumbs/files/patch-cmake__FindFFmpeg.cmake45
4 files changed, 76 insertions, 6 deletions
diff --git a/multimedia/kdemultimedia4-ffmpegthumbs/Makefile b/multimedia/kdemultimedia4-ffmpegthumbs/Makefile
index e9e1d813d4e3..7d8aa5e5bee7 100644
--- a/multimedia/kdemultimedia4-ffmpegthumbs/Makefile
+++ b/multimedia/kdemultimedia4-ffmpegthumbs/Makefile
@@ -7,21 +7,26 @@ CATEGORIES= multimedia kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
PKGNAMEPREFIX= kdemultimedia-
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
-COMMENT= ffmpeg-based thumbnail creator for video files
+COMMENT= FFmpeg-based thumbnail generator for video files
LICENSE= GPLv2
-LIB_DEPENDS= swscale.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS= swscale${FFMPEG_SUFFIX}:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX}
CONFLICTS_INSTALL= kdemultimedia-4.[1-8].*
-MAKE_JOBS_SAFE= yes
USES= cmake:outsource
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+
+# supported versions: ffmpeg1, ffmpeg-devel
+# corresponding FFMPEG_SUFFIX: '1', '-devel'
+FFMPEG_SUFFIX?= 1
+CMAKE_ARGS+= -DFFMPEG_SUFFIX=${FFMPEG_SUFFIX}
.include <bsd.port.mk>
diff --git a/multimedia/kdemultimedia4-ffmpegthumbs/distinfo b/multimedia/kdemultimedia4-ffmpegthumbs/distinfo
index d29981875168..aeb45f67a097 100644
--- a/multimedia/kdemultimedia4-ffmpegthumbs/distinfo
+++ b/multimedia/kdemultimedia4-ffmpegthumbs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/ffmpegthumbs-4.9.5.tar.xz) = 32efd9b83c569aafaae64cb9f5cc78943adf54fb4061a131749cb921a5ac0e46
-SIZE (KDE/ffmpegthumbs-4.9.5.tar.xz) = 20788
+SHA256 (KDE/4.10.1/ffmpegthumbs-4.10.1.tar.xz) = d1ee276056de2d197460cb664b20db6d56a6bf7e2ab8e477316a01d67afd6144
+SIZE (KDE/4.10.1/ffmpegthumbs-4.10.1.tar.xz) = 20824
diff --git a/multimedia/kdemultimedia4-ffmpegthumbs/files/patch-CMakeLists.txt b/multimedia/kdemultimedia4-ffmpegthumbs/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..09fbeb4129cc
--- /dev/null
+++ b/multimedia/kdemultimedia4-ffmpegthumbs/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+# Reorder include directories to allow build with multiple ffmpeg installed.
+# This patch must NOT be used, if FFMPEG_INCLUDE_DIRS == ${LOCALBASE}/include
+#
+--- ./CMakeLists.txt.orig 2013-03-01 07:07:31.562142000 +0000
++++ ./CMakeLists.txt 2013-03-06 00:33:28.482362201 +0000
+@@ -7,11 +7,11 @@
+ find_package(FFmpeg COMPONENTS AVCODEC AVFORMAT SWSCALE)
+
+ include_directories(
+- ${KDE4_INCLUDES}
+- ${CMAKE_CURRENT_BINARY_DIR}
++ ${FFMPEG_INCLUDE_DIR}
+ ${PC_AVCODEC_INCLUDEDIR}
+ ${PC_AVFORMAT_INCLUDEDIR}
+- ${FFMPEG_INCLUDE_DIR}
++ ${KDE4_INCLUDES}
++ ${CMAKE_CURRENT_BINARY_DIR}
+ )
+
+ # Certain versions of FFMPEG need this to be defined
diff --git a/multimedia/kdemultimedia4-ffmpegthumbs/files/patch-cmake__FindFFmpeg.cmake b/multimedia/kdemultimedia4-ffmpegthumbs/files/patch-cmake__FindFFmpeg.cmake
new file mode 100644
index 000000000000..2ab29a6ffb80
--- /dev/null
+++ b/multimedia/kdemultimedia4-ffmpegthumbs/files/patch-cmake__FindFFmpeg.cmake
@@ -0,0 +1,45 @@
+--- ./cmake/FindFFmpeg.cmake.orig 2013-03-01 07:07:31.562142000 +0000
++++ ./cmake/FindFFmpeg.cmake 2013-03-06 00:32:09.269367542 +0000
+@@ -71,13 +71,15 @@
+ ${PC_LIB${_component}_INCLUDEDIR}
+ ${PC_LIB${_component}_INCLUDE_DIRS}
+ PATH_SUFFIXES
+- ffmpeg
++ ffmpeg${FFMPEG_SUFFIX}
+ )
+
+ find_library(${_component}_LIBRARIES NAMES ${_library}
+- HINTS
++ HINTS
+ ${PC_LIB${_component}_LIBDIR}
+ ${PC_LIB${_component}_LIBRARY_DIRS}
++ PATH_SUFFIXES
++ ffmpeg${FFMPEG_SUFFIX}
+ )
+
+ set(${_component}_DEFINITIONS ${PC_${_component}_CFLAGS_OTHER} CACHE STRING "The ${_component} CFLAGS.")
+@@ -97,13 +99,18 @@
+ # Check for cached results. If there are skip the costly part.
+ if (NOT FFMPEG_LIBRARIES)
+
++ # Look for ffmpeg1 by default. Use empty suffix for ffmpeg-0.7
++ if (NOT DEFINED FFMPEG_SUFFIX)
++ set(FFMPEG_SUFFIX 1)
++ endif ()
++
+ # Check for all possible component.
+- find_component(AVCODEC libavcodec avcodec libavcodec/avcodec.h)
+- find_component(AVFORMAT libavformat avformat libavformat/avformat.h)
+- find_component(AVDEVICE libavdevice avdevice libavdevice/avdevice.h)
+- find_component(AVUTIL libavutil avutil libavutil/avutil.h)
+- find_component(SWSCALE libswscale swscale libswscale/swscale.h)
+- find_component(POSTPROC libpostproc postproc libpostproc/postprocess.h)
++ find_component(AVCODEC libavcodec${FFMPEG_SUFFIX} avcodec${FFMPEG_SUFFIX} libavcodec/avcodec.h)
++ find_component(AVFORMAT libavformat${FFMPEG_SUFFIX} avformat${FFMPEG_SUFFIX} libavformat/avformat.h)
++ find_component(AVDEVICE libavdevice${FFMPEG_SUFFIX} avdevice${FFMPEG_SUFFIX} libavdevice/avdevice.h)
++ find_component(AVUTIL libavutil${FFMPEG_SUFFIX} avutil${FFMPEG_SUFFIX} libavutil/avutil.h)
++ find_component(SWSCALE libswscale${FFMPEG_SUFFIX} swscale${FFMPEG_SUFFIX} libswscale/swscale.h)
++ find_component(POSTPROC libpostproc${FFMPEG_SUFFIX} postproc${FFMPEG_SUFFIX} libpostproc/postprocess.h)
+
+ # Check if the required components were found and add their stuff to the FFMPEG_* vars.
+ foreach (_component ${FFmpeg_FIND_COMPONENTS})