aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kdenlive
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2014-09-24 09:14:40 +0800
committeravilla <avilla@FreeBSD.org>2014-09-24 09:14:40 +0800
commitab666936373db72378d43e847e47675eec6bbd9d (patch)
treed6db259221dc271426a36cab90bd8db9d7942630 /multimedia/kdenlive
parentbbb25e952128c4313852f42085d3ae221b16f0ef (diff)
downloadfreebsd-ports-gnome-ab666936373db72378d43e847e47675eec6bbd9d.tar.gz
freebsd-ports-gnome-ab666936373db72378d43e847e47675eec6bbd9d.tar.zst
freebsd-ports-gnome-ab666936373db72378d43e847e47675eec6bbd9d.zip
- Update to 0.9.8.
- Add V4L option to enable webcam support. - Use OPTIONS helpers. - Remove @dirrm*. Release 0.9.8 brings several fixes: http://kdenlive.org/discover/0.9.8
Diffstat (limited to 'multimedia/kdenlive')
-rw-r--r--multimedia/kdenlive/Makefile58
-rw-r--r--multimedia/kdenlive/distinfo4
-rw-r--r--multimedia/kdenlive/files/patch-src__CMakeLists.txt11
-rw-r--r--multimedia/kdenlive/files/patch-src__recmonitor.cpp11
-rw-r--r--multimedia/kdenlive/files/patch-src__wizard.cpp13
-rw-r--r--multimedia/kdenlive/pkg-plist56
6 files changed, 23 insertions, 130 deletions
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index 4850d4897f28..6c3894519f5b 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= kdenlive
-PORTVERSION= 0.9.6
-PORTREVISION= 5
+PORTVERSION= 0.9.8
CATEGORIES= multimedia kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src/
@@ -24,58 +23,43 @@ USES= cmake pkgconfig shared-mime-info tar:bzip2
CMAKE_ARGS= -DFFMPEG_SUFFIX:STRING="${FFMPEG_SUFX}"
# Keep in sync with multimedia/mlt, possibly.
-FFMPEG_SUFX=
+FFMPEG_SUFX= # Currently empty.
-OPTIONS_DEFINE= DVDWIZARD FREI0R LADSPA NLS SCREENCAST XINE
-OPTIONS_DEFAULT=DVDWIZARD FREI0R LADSPA SCREENCAST XINE
+OPTIONS_DEFINE= DVDWIZARD FREI0R LADSPA NLS SCREENCAST V4L XINE
+OPTIONS_DEFAULT=DVDWIZARD FREI0R LADSPA SCREENCAST V4L XINE
+OPTIONS_SUB= yes
DVDWIZARD_DESC= DVD authoring via DVDAuthor and cdrtools
SCREENCAST_DESC=Screen capture support via recordMyDesktop
-#V4L_DESC= Webcam support via Video 4 Linux
+V4L_DESC= Webcam support via Video 4 Linux
XINE_DESC= DVD preview support via xine
-.include <bsd.port.options.mk>
+DVDWIZARD_RUN_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
-.if ${PORT_OPTIONS:MDVDWIZARD}
-RUN_DEPENDS+= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
- cdrecord:${PORTSDIR}/sysutils/cdrtools
-.endif
+FREI0R_RUN_DEPENDS= frei0r-plugins>=0:${PORTSDIR}/graphics/frei0r-plugins
-.if ${PORT_OPTIONS:MFREI0R}
-RUN_DEPENDS+= frei0r-plugins>=0:${PORTSDIR}/graphics/frei0r-plugins
-.endif
+LADSPA_RUN_DEPENDS= swhplugins>=0:${PORTSDIR}/audio/swhplugins
-.if ${PORT_OPTIONS:MLADSPA}
-RUN_DEPENDS+= swhplugins>=0:${PORTSDIR}/audio/swhplugins
-.endif
+NLS_USES= gettext
+NLS_CMAKE_OFF= -DBUILD_po:BOOL=FALSE
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CMAKE_ARGS+= -DBUILD_po:BOOL=FALSE
-PLIST_SUB+= NLS="@comment "
-.endif
+SCREENCAST_RUN_DEPENDS= recordmydesktop:${PORTSDIR}/multimedia/recordmydesktop
-.if ${PORT_OPTIONS:MSCREENCAST}
-RUN_DEPENDS+= recordmydesktop:${PORTSDIR}/multimedia/recordmydesktop
-.endif
+V4L_LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
+V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
+V4L_CMAKE_OFF= -DWITH_LibV4L2:BOOL=FALSE
-#.if ${PORT_OPTIONS:MV4L}
-#LIB_DEPENDS+= v4l2:${PORTSDIR}/multimedia/libv4l
-#BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
-#.else
-CMAKE_ARGS+= -DWITH_V4L:BOOL=FALSE
-#.endif
-
-.if ${PORT_OPTIONS:MXINE}
-RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
-.endif
+XINE_RUN_DEPENDS= xine:${PORTSDIR}/multimedia/xine
post-patch:
@${REINPLACE_CMD} -E -e '/${PORTNAME}.(menu|xpm)/ d' \
${PATCH_WRKSRC}/data/CMakeLists.txt
@${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d; /SharedMimeInfo/ d' \
${PATCH_WRKSRC}/src/mimetypes/CMakeLists.txt
+.for lang in bs ca ca@valencia cs da de el es et fi fr ga gl he hr hu it ja lt mr nb nds nl pl pt pt_BR ro ru sk sl sv tr ug uk zh_CN zh_TW
+ @${REINPLACE_CMD} -e 's,fr ALL,${lang} ALL,' \
+ ${PATCH_WRKSRC}/po/${lang}/CMakeLists.txt
+.endfor
.include <bsd.port.mk>
diff --git a/multimedia/kdenlive/distinfo b/multimedia/kdenlive/distinfo
index 6b532eb4f10d..392eb9d99f0a 100644
--- a/multimedia/kdenlive/distinfo
+++ b/multimedia/kdenlive/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kdenlive-0.9.6.tar.bz2) = fdc447135428864a283c48122f8bffc236fa2e5cdffbbc65e44bd5e2ff6282e7
-SIZE (kdenlive-0.9.6.tar.bz2) = 5355764
+SHA256 (kdenlive-0.9.8.tar.bz2) = 96ca31f9f6d4dc339b1e1daf46ec0803516118e712a5a2d75d9433ee5fd6a59f
+SIZE (kdenlive-0.9.8.tar.bz2) = 4775988
diff --git a/multimedia/kdenlive/files/patch-src__CMakeLists.txt b/multimedia/kdenlive/files/patch-src__CMakeLists.txt
deleted file mode 100644
index 5ed9d6dc5a61..000000000000
--- a/multimedia/kdenlive/files/patch-src__CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/CMakeLists.txt.orig 2013-04-06 21:25:09.000000000 +0200
-+++ ./src/CMakeLists.txt 2013-06-05 15:33:12.402759625 +0200
-@@ -14,6 +14,8 @@
- option(WITH_V4L "Build capture support with Video4Linux" ON)
- option(WITH_JogShuttle "Build Jog/Shuttle support" ON)
-
-+set(FFMPEG_SUFFIX "" CACHE STRING "FFmpeg custom suffix")
-+add_definitions(-DFFMPEG_SUFFIX=\\\"\"${FFMPEG_SUFFIX}\"\\\")
-
-
- if(WITH_V4L)
diff --git a/multimedia/kdenlive/files/patch-src__recmonitor.cpp b/multimedia/kdenlive/files/patch-src__recmonitor.cpp
deleted file mode 100644
index c3cc0771ab46..000000000000
--- a/multimedia/kdenlive/files/patch-src__recmonitor.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/recmonitor.cpp.orig 2013-04-06 21:25:09.000000000 +0200
-+++ ./src/recmonitor.cpp 2013-06-05 15:37:14.742805014 +0200
-@@ -269,7 +269,7 @@
- m_stopAction->setEnabled(false);
- m_playAction->setEnabled(false);
- if (KdenliveSettings::ffmpegpath().isEmpty()) {
-- QString exepath = KStandardDirs::findExe("ffmpeg");
-+ QString exepath = KStandardDirs::findExe(QString("ffmpeg%1").arg(FFMPEG_SUFFIX));
- if (exepath.isEmpty()) {
- // Check for libav version
- exepath = KStandardDirs::findExe("avconv");
diff --git a/multimedia/kdenlive/files/patch-src__wizard.cpp b/multimedia/kdenlive/files/patch-src__wizard.cpp
deleted file mode 100644
index c6de970a5bbd..000000000000
--- a/multimedia/kdenlive/files/patch-src__wizard.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/wizard.cpp.orig 2013-04-06 21:25:09.000000000 +0200
-+++ ./src/wizard.cpp 2013-06-07 14:37:07.694597426 +0200
-@@ -499,8 +499,8 @@
- QTreeWidgetItem *item = new QTreeWidgetItem(m_check.programList, QStringList() << QString() << i18n("FFmpeg & ffplay"));
- item->setData(1, Qt::UserRole, i18n("Required for proxy clips, transcoding and screen capture"));
- item->setSizeHint(0, itemSize);
-- QString exepath = KStandardDirs::findExe("ffmpeg");
-- QString playpath = KStandardDirs::findExe("ffplay");
-+ QString exepath = KStandardDirs::findExe(QString("ffmpeg%1").arg(FFMPEG_SUFFIX));
-+ QString playpath = KStandardDirs::findExe(QString("ffplay%1").arg(FFMPEG_SUFFIX));
- item->setIcon(0, m_okIcon);
- if (exepath.isEmpty()) {
- // Check for libav version
diff --git a/multimedia/kdenlive/pkg-plist b/multimedia/kdenlive/pkg-plist
index 8816e5830170..b6a5d4233f46 100644
--- a/multimedia/kdenlive/pkg-plist
+++ b/multimedia/kdenlive/pkg-plist
@@ -170,9 +170,6 @@ share/config/kdenlive_titles.knsrc
share/config/kdenlive_wipes.knsrc
share/config/kdenliveeffectscategory.rc
share/config/kdenlivetranscodingrc
-share/doc/HTML/ca/kdenlive/common
-share/doc/HTML/ca/kdenlive/index.cache.bz2
-share/doc/HTML/ca/kdenlive/index.docbook
share/doc/HTML/en/kdenlive/Kdenlive-Quickstart-Add-Last-Clip.png
share/doc/HTML/en/kdenlive/Kdenlive-Quickstart-Add-Transition.png
share/doc/HTML/en/kdenlive/Kdenlive-Quickstart-EffectStack.png
@@ -194,43 +191,6 @@ share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-TimelineCursor.png
share/doc/HTML/en/kdenlive/common
share/doc/HTML/en/kdenlive/index.cache.bz2
share/doc/HTML/en/kdenlive/index.docbook
-share/doc/HTML/es/kdenlive/common
-share/doc/HTML/es/kdenlive/index.cache.bz2
-share/doc/HTML/es/kdenlive/index.docbook
-share/doc/HTML/it/kdenlive/common
-share/doc/HTML/it/kdenlive/index.cache.bz2
-share/doc/HTML/it/kdenlive/index.docbook
-share/doc/HTML/nl/kdenlive/common
-share/doc/HTML/nl/kdenlive/index.cache.bz2
-share/doc/HTML/nl/kdenlive/index.docbook
-share/doc/HTML/pt/kdenlive/common
-share/doc/HTML/pt/kdenlive/index.cache.bz2
-share/doc/HTML/pt/kdenlive/index.docbook
-share/doc/HTML/pt_BR/kdenlive/common
-share/doc/HTML/pt_BR/kdenlive/index.cache.bz2
-share/doc/HTML/pt_BR/kdenlive/index.docbook
-share/doc/HTML/sv/kdenlive/common
-share/doc/HTML/sv/kdenlive/index.cache.bz2
-share/doc/HTML/sv/kdenlive/index.docbook
-share/doc/HTML/uk/kdenlive/Kdenlive-Quickstart-Add-Last-Clip.png
-share/doc/HTML/uk/kdenlive/Kdenlive-Quickstart-Add-Transition.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Add-Clips.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Add-Effect.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Effect-Flag.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Fadeout.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Folder-Structure.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Mainwindow.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-New-Project.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Overlap-Clips.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Renderer.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Rendering.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Resize-Marker.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Save-Project.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Timeline-Clips.png
-share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-TimelineCursor.png
-share/doc/HTML/uk/kdenlive/common
-share/doc/HTML/uk/kdenlive/index.cache.bz2
-share/doc/HTML/uk/kdenlive/index.docbook
share/icons/hicolor/128x128/actions/kdenlive-select-all.png
share/icons/hicolor/128x128/mimetypes/application-x-kdenlivetitle.png
share/icons/hicolor/16x16/actions/kdenlive-add-clip.png
@@ -431,19 +391,3 @@ share/kde4/services/westleypreview.desktop
%%NLS%%share/locale/zh_TW/LC_MESSAGES/kdenlive.mo
share/mime/packages/kdenlive.xml
share/mime/packages/westley.xml
-@dirrm share/doc/HTML/uk/kdenlive
-@dirrm share/doc/HTML/sv/kdenlive
-@dirrm share/doc/HTML/pt_BR/kdenlive
-@dirrm share/doc/HTML/pt/kdenlive
-@dirrm share/doc/HTML/nl/kdenlive
-@dirrm share/doc/HTML/it/kdenlive
-@dirrm share/doc/HTML/es/kdenlive
-@dirrm share/doc/HTML/en/kdenlive
-@dirrm share/doc/HTML/ca/kdenlive
-@dirrm share/apps/kdenlive/titles
-@dirrm share/apps/kdenlive/pics
-@dirrm share/apps/kdenlive/lumas
-@dirrm share/apps/kdenlive/export
-@dirrm share/apps/kdenlive/effects/update
-@dirrm share/apps/kdenlive/effects
-@dirrm share/apps/kdenlive