aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kodi
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-09-20 09:11:40 +0800
committerjbeich <jbeich@FreeBSD.org>2015-09-20 09:11:40 +0800
commit5706888fc0fd0be273e807b06ee5bedba794be46 (patch)
treedebc40bb77f2a4f0f9cc504b900f3a7217f6ae37 /multimedia/kodi
parent55134ae1d0c762bb2003b18f4b9269061b3668a4 (diff)
downloadfreebsd-ports-gnome-5706888fc0fd0be273e807b06ee5bedba794be46.tar.gz
freebsd-ports-gnome-5706888fc0fd0be273e807b06ee5bedba794be46.tar.zst
freebsd-ports-gnome-5706888fc0fd0be273e807b06ee5bedba794be46.zip
multimedia/kodi: minor cleanup
- Convert to USE_GL - Convert _VARS option helper - Adjust PLIST_SUB outside of conditional - Drop 8.x support Approved by: portmgr blanket
Diffstat (limited to 'multimedia/kodi')
-rw-r--r--multimedia/kodi/Makefile29
1 files changed, 8 insertions, 21 deletions
diff --git a/multimedia/kodi/Makefile b/multimedia/kodi/Makefile
index dcede8f2eb4c..7a3adca8adba 100644
--- a/multimedia/kodi/Makefile
+++ b/multimedia/kodi/Makefile
@@ -31,7 +31,6 @@ LIB_DEPENDS= libass.so:${PORTSDIR}/multimedia/libass \
libdbus-1.so:${PORTSDIR}/devel/dbus \
libdrm.so:${PORTSDIR}/graphics/libdrm \
libenca.so:${PORTSDIR}/converters/enca \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libFLAC.so:${PORTSDIR}/audio/flac \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2 \
@@ -65,16 +64,21 @@ USES= autoreconf:build gettext gmake iconv:wchar_t jpeg libtool \
pkgconfig python:2
GNU_CONFIGURE= yes
USE_XORG= xt xmu xtst xrandr
-USE_GL= glu
+USE_GL= glu glew
USE_SDL= image sdl2
USE_JAVA= yes
JAVA_BUILD= jre
NOPRECIOUSMAKEVARS= yes
INSTALLS_ICONS= yes
+
ONLY_FOR_ARCHS= i386 amd64
+KODI_ARCH_i386= x86
+KODI_ARCH_amd64=x86_64
WRKSRC= ${WRKDIR}/xbmc-${DISTVERSION}-Helix
+PLIST_SUB= ARCH=${KODI_ARCH_${ARCH}}
+
OPTIONS_SUB= yes
OPTIONS_DEFINE= AIRPLAY AIRTUNES AVAHI CEC DOCS \
LIBBLURAY LIRC MYSQL NFS NONFREE RTMP \
@@ -113,6 +117,8 @@ NFS_LIB_DEPENDS= libnfs.so:${PORTSDIR}/net/libnfs
NFS_CONFIGURE_ENABLE= nfs
NONFREE_CONFIGURE_ENABLE= non-free
+NONFREE_VARS= NO_CDROM="Restricted binary distribution" \
+ NO_PACKAGE="Restricted binary distribution"
RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/librtmp
RTMP_CONFIGURE_ENABLE= rtmp
@@ -136,25 +142,6 @@ SFTP_CONFIGURE_ENABLE= ssh
CONFIGURE_ARGS+= --disable-debug --disable-alsa --disable-pulse
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == i386
-PLIST_SUB+= ARCH="x86"
-.else
-PLIST_SUB+= ARCH="x86_64"
-.endif
-
-.if ${OSVERSION} < 900033
-BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
-CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
-MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
-.endif
-
-.if ${PORT_OPTIONS:MNONFREE}
-NO_CDROM= Restricted binary distribution
-NO_PACKAGE= ${NO_CDROM}
-.endif
-
post-extract:
${MKDIR} ${WRKSRC}/tools/depends/target/ffmpeg/${GH_PROJECT}-${GH_TAGNAME}
${TAR} --strip-components=1 -xf ${DISTDIR}/${GH_PROJECT}-${GH_TAGNAME}.tar.gz \