aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libdvdread
diff options
context:
space:
mode:
authorkoitsu <koitsu@FreeBSD.org>2007-04-05 14:03:23 +0800
committerkoitsu <koitsu@FreeBSD.org>2007-04-05 14:03:23 +0800
commitb1c0d29a2e7cf55e06bd33b7dfce08d4cb7f2d66 (patch)
treebb79dbed3bd00056d38938404ae5481fbc293a1c /multimedia/libdvdread
parent968df6a6de5487b567e39a0590af77b556f2a4d0 (diff)
downloadfreebsd-ports-gnome-b1c0d29a2e7cf55e06bd33b7dfce08d4cb7f2d66.tar.gz
freebsd-ports-gnome-b1c0d29a2e7cf55e06bd33b7dfce08d4cb7f2d66.tar.zst
freebsd-ports-gnome-b1c0d29a2e7cf55e06bd33b7dfce08d4cb7f2d66.zip
* libdvdread - PORTREVISION increment
* libdvdread - add patch for including <stdlib.h> in dvdread/ifo_types.h * Others - LIB_DEPENDS changes (require libdvdread.so.5) * Others - PORTREVISION increment for those dependent on libdvdread Approved by: philip
Diffstat (limited to 'multimedia/libdvdread')
-rw-r--r--multimedia/libdvdread/Makefile2
-rw-r--r--multimedia/libdvdread/files/patch-dvdread-ifo_types.h15
2 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index 1d50f16bb878..aa603e59db76 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libdvdread
PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
diff --git a/multimedia/libdvdread/files/patch-dvdread-ifo_types.h b/multimedia/libdvdread/files/patch-dvdread-ifo_types.h
new file mode 100644
index 000000000000..3ac3b5737be9
--- /dev/null
+++ b/multimedia/libdvdread/files/patch-dvdread-ifo_types.h
@@ -0,0 +1,15 @@
+--- dvdread/ifo_types.h.orig Thu Mar 2 17:25:43 2006
++++ dvdread/ifo_types.h Wed Apr 4 20:07:32 2007
+@@ -29,7 +29,11 @@
+ #endif
+ #else
+ #if !defined(UINT8_MAX) || !defined(UINT16_MAX) || !defined(INT32_MAX)
+-#error "Must include <inttypes.h> or <stdint.h> before any libdvdread header."
++#if !defined(_SYS_STDINT_H_) || !defined(_INTTYPES_H_)
++#include <stdint.h>
++#else
++#error "UINT8_MAX, UINT16_MAX, or INT32_MAX are missing from <stdint.h> or <inttypes.h>."
++#endif
+ #endif
+ #endif
+