aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libva-utils/Makefile
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2019-03-13 00:00:23 +0800
committermadpilot <madpilot@FreeBSD.org>2019-03-13 00:00:23 +0800
commit5f8d5b578cfb0aa348f2dfc0c2ee6fb839dc23e4 (patch)
treeba40b7a797618c64c2bbbb9811af8b70a174f55c /multimedia/libva-utils/Makefile
parentc426fe32d2ade320b122da80f19347f4257437f5 (diff)
downloadfreebsd-ports-gnome-5f8d5b578cfb0aa348f2dfc0c2ee6fb839dc23e4.tar.gz
freebsd-ports-gnome-5f8d5b578cfb0aa348f2dfc0c2ee6fb839dc23e4.tar.zst
freebsd-ports-gnome-5f8d5b578cfb0aa348f2dfc0c2ee6fb839dc23e4.zip
Add option to disable X11 support.
Requested by: driesm.michiels@gmail.com
Diffstat (limited to 'multimedia/libva-utils/Makefile')
-rw-r--r--multimedia/libva-utils/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/multimedia/libva-utils/Makefile b/multimedia/libva-utils/Makefile
index 28970528308f..d9d19c978114 100644
--- a/multimedia/libva-utils/Makefile
+++ b/multimedia/libva-utils/Makefile
@@ -14,15 +14,15 @@ LIB_DEPENDS= libva.so:multimedia/libva \
libdrm.so:graphics/libdrm
USES= autoreconf compiler:c++11-lang gmake libtool pkgconfig tar:bzip2
-USE_XORG= x11 xext xfixes
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_GITHUB= yes
GH_ACCOUNT= intel
-OPTIONS_DEFINE= DEBUG WAYLAND
-OPTIONS_DEFAULT=WAYLAND
+OPTIONS_DEFINE= DEBUG WAYLAND X11
+OPTIONS_DEFAULT=WAYLAND X11
WAYLAND_DESC= Support wayland protocol
OPTIONS_SUB= yes
@@ -32,4 +32,7 @@ DEBUG_CFLAGS_OFF= -DNDEBUG
WAYLAND_CONFIGURE_ENABLE= wayland
WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland
+X11_CONFIGURE_ENABLE= x11
+X11_USE= XORG=x11,xext,xfixes
+
.include <bsd.port.mk>