aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libvpx
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2015-06-01 02:58:16 +0800
committerSean Bruno <sbruno@FreeBSD.org>2015-06-01 02:58:16 +0800
commitb84c1e69639515233eee67084802eda1378ea41a (patch)
treea05917594bae8e194a4fea71bf8558009cb6f4c9 /multimedia/libvpx
parent2034059dffe3f8debdef6f06ae86b4f905d59a72 (diff)
downloadfreebsd-ports-gnome-b84c1e69639515233eee67084802eda1378ea41a.tar.gz
freebsd-ports-gnome-b84c1e69639515233eee67084802eda1378ea41a.tar.zst
freebsd-ports-gnome-b84c1e69639515233eee67084802eda1378ea41a.zip
Fix build error introduced by changes to default behavior of perl port.
Apply shebangfix to build/make/ads2gas.pl as it was invoking /usr/bin/perl. PR: 200535 Reviewed by: kwm
Diffstat (limited to 'multimedia/libvpx')
-rw-r--r--multimedia/libvpx/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/multimedia/libvpx/Makefile b/multimedia/libvpx/Makefile
index bd1bdf4a14eb..fb51d57c11fc 100644
--- a/multimedia/libvpx/Makefile
+++ b/multimedia/libvpx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libvpx
PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${DISTVERSION}.orig
@@ -16,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
yasm:${PORTSDIR}/devel/yasm
-USES= cpe gmake perl5 tar:bzip2
+USES= cpe gmake perl5 shebangfix tar:bzip2
CPE_VENDOR= john_koleszar
HAS_CONFIGURE= yes
USE_PERL5= build
@@ -48,6 +49,8 @@ RUNTIME_CONFIGURE_ON= --enable-runtime-cpu-detect
THREADS_CONFIGURE_OFF= --disable-multithread
SHARED_CONFIGURE_ON= --enable-shared
+SHEBANG_FILES= build/make/ads2gas.pl
+
.include <bsd.port.options.mk>
.if ${OSVERSION} < 900000