aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libxine/files
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-10-27 00:58:00 +0800
committerlioux <lioux@FreeBSD.org>2001-10-27 00:58:00 +0800
commit586b24b0caf5cd76463ec4b889d2e37077126072 (patch)
tree9ad099c7344919598fb7cb1fec45d8c2d2c34ee6 /multimedia/libxine/files
parent9fcd5364f0049302161cadbaecdd81c48bb140ac (diff)
downloadfreebsd-ports-gnome-586b24b0caf5cd76463ec4b889d2e37077126072.tar.gz
freebsd-ports-gnome-586b24b0caf5cd76463ec4b889d2e37077126072.tar.zst
freebsd-ports-gnome-586b24b0caf5cd76463ec4b889d2e37077126072.zip
o update to 0.9.2
o use ports libraries instead of internal versions: liba52 and ffmpeg o support for both vorbis and ogg o WITH_CSS: plugin for css processing o add WWW tag to DESCR Reviewed by: MAINTAINER, freebsd-multimedia
Diffstat (limited to 'multimedia/libxine/files')
-rw-r--r--multimedia/libxine/files/patch-src:liba52:Makefile.am18
-rw-r--r--multimedia/libxine/files/patch-src:liba52:xine_decoder.c13
-rw-r--r--multimedia/libxine/files/patch-src:libffmpeg:Makefile.am25
-rw-r--r--multimedia/libxine/files/patch-src:libffmpeg:xine_decoder.c13
-rw-r--r--multimedia/libxine/files/patch-src:xine-engine:Makefile.am12
-rw-r--r--multimedia/libxine/files/patch-src:xine-engine:Makefile.in11
6 files changed, 81 insertions, 11 deletions
diff --git a/multimedia/libxine/files/patch-src:liba52:Makefile.am b/multimedia/libxine/files/patch-src:liba52:Makefile.am
new file mode 100644
index 000000000000..07d0af4922c9
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:liba52:Makefile.am
@@ -0,0 +1,18 @@
+--- src/liba52/Makefile.am.orig Fri Oct 19 16:55:18 2001
++++ src/liba52/Makefile.am Fri Oct 19 16:57:31 2001
+@@ -8,13 +8,9 @@
+
+ lib_LTLIBRARIES = xineplug_decode_a52.la
+
+-xineplug_decode_a52_la_SOURCES = bitstream.c bit_allocate.c \
+- parse.c downmix.c imdct.c imdct_mlib.c \
+- xine_decoder.c
++xineplug_decode_a52_la_SOURCES = xine_decoder.c
++xineplug_decode_a52_la_LIBADD = -la52
+ xineplug_decode_a52_la_LDFLAGS = -avoid-version -module
+-
+-noinst_HEADERS = a52.h a52_internal.h \
+- bitstream.h tables.h
+
+ ##
+ ## Install header files (default=$includedir/xine)
diff --git a/multimedia/libxine/files/patch-src:liba52:xine_decoder.c b/multimedia/libxine/files/patch-src:liba52:xine_decoder.c
new file mode 100644
index 000000000000..926881161212
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:liba52:xine_decoder.c
@@ -0,0 +1,13 @@
+--- src/liba52/xine_decoder.c.orig Fri Oct 19 17:55:03 2001
++++ src/liba52/xine_decoder.c Fri Oct 19 17:55:31 2001
+@@ -31,8 +31,8 @@
+ #include <fcntl.h>
+
+ #include "audio_out.h"
+-#include "a52.h"
+-#include "a52_internal.h"
++#include <a52dec/a52.h>
++#include <a52dec/a52_internal.h>
+ #include "buffer.h"
+ #include "xine_internal.h"
+ #include "cpu_accel.h"
diff --git a/multimedia/libxine/files/patch-src:libffmpeg:Makefile.am b/multimedia/libxine/files/patch-src:libffmpeg:Makefile.am
new file mode 100644
index 000000000000..587a80910811
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:libffmpeg:Makefile.am
@@ -0,0 +1,25 @@
+--- src/libffmpeg/Makefile.am.orig Fri Oct 19 21:19:47 2001
++++ src/libffmpeg/Makefile.am Fri Oct 19 21:23:02 2001
+@@ -2,7 +2,6 @@
+ ## Process this file with automake to produce Makefile.in
+ ##
+
+-SUBDIRS = libavcodec
+
+ CFLAGS = @GLOBAL_CFLAGS@
+
+@@ -13,12 +12,9 @@
+ lib_LTLIBRARIES = xineplug_decode_ff.la
+
+ xineplug_decode_ff_la_SOURCES = xine_decoder.c
++xineplug_decode_ff_la_LIBADD = -lavcodec
++xineplug_decode_ff_la_LDFLAGS = -avoid-version -module
+
+-xineplug_decode_ff_la_LDFLAGS = \
+- $(top_builddir)/src/libffmpeg/libavcodec/libavcodec.la \
+- -avoid-version -module
+-
+-noinst_HEADERS = config.h
+
+ debug:
+ @list='$(SUBDIRS)'; for subdir in $$list; do \
diff --git a/multimedia/libxine/files/patch-src:libffmpeg:xine_decoder.c b/multimedia/libxine/files/patch-src:libffmpeg:xine_decoder.c
new file mode 100644
index 000000000000..949357430d4c
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:libffmpeg:xine_decoder.c
@@ -0,0 +1,13 @@
+--- src/libffmpeg/xine_decoder.c.orig Fri Oct 19 21:17:15 2001
++++ src/libffmpeg/xine_decoder.c Fri Oct 19 21:17:39 2001
+@@ -38,8 +38,8 @@
+ #include "buffer.h"
+ #include "metronom.h"
+
+-#include "libavcodec/avcodec.h"
+-#include "libavcodec/dsputil.h"
++#include <libavcodec/avcodec.h>
++#include <libavcodec/dsputil.h>
+
+ /* now this is ripped of wine's vfw.h */
+ typedef struct {
diff --git a/multimedia/libxine/files/patch-src:xine-engine:Makefile.am b/multimedia/libxine/files/patch-src:xine-engine:Makefile.am
new file mode 100644
index 000000000000..dc8aa08f2b97
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:xine-engine:Makefile.am
@@ -0,0 +1,12 @@
+--- src/xine-engine/Makefile.am.orig Sun Oct 21 09:06:25 2001
++++ src/xine-engine/Makefile.am Sun Oct 21 09:07:43 2001
+@@ -18,8 +18,7 @@
+ -lm
+
+ libxine_la_LDFLAGS = \
+- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
+- -release $(LT_RELEASE)
++ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+
+ include_HEADERS = buffer.h metronom.h configfile.h \
+ monitor.h cpu_accel.h attributes.h utils.h \
diff --git a/multimedia/libxine/files/patch-src:xine-engine:Makefile.in b/multimedia/libxine/files/patch-src:xine-engine:Makefile.in
deleted file mode 100644
index 4c04a5c3d299..000000000000
--- a/multimedia/libxine/files/patch-src:xine-engine:Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xine-engine/Makefile.in.orig Thu Sep 20 03:13:58 2001
-+++ src/xine-engine/Makefile.in Thu Sep 20 03:14:49 2001
-@@ -142,7 +142,7 @@
- libxine_la_LIBADD = cpu_accel.lo $(THREAD_LIBS) $(DYNAMIC_LD_LIBS) -lm
-
-
--libxine_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
-+libxine_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
-
- include_HEADERS = buffer.h metronom.h configfile.h monitor.h cpu_accel.h attributes.h utils.h audio_out.h resample.h video_out.h xine_internal.h spu_decoder.h events.h