aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mkclean
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-09-29 05:18:31 +0800
committerbapt <bapt@FreeBSD.org>2011-09-29 05:18:31 +0800
commit9436063a2997925ca27a232721fd9e94cec2b386 (patch)
tree72e7d6eedba4b49a199740e09cadef9aeec78538 /multimedia/mkclean
parent0758161de83e898e12ddcb304f653a3014ef506a (diff)
downloadfreebsd-ports-gnome-9436063a2997925ca27a232721fd9e94cec2b386.tar.gz
freebsd-ports-gnome-9436063a2997925ca27a232721fd9e94cec2b386.tar.zst
freebsd-ports-gnome-9436063a2997925ca27a232721fd9e94cec2b386.zip
- update to 0.8.6
- take maintainership [1] - add license - respect PREFIX - remove the broken on sparc64 seems to have been fixed upstream, but I have no way to test it - only provide the mkclean binary, no more the testing mkvtree Approved by: johnson.peter@gmail.com (previous maintainer)
Diffstat (limited to 'multimedia/mkclean')
-rw-r--r--multimedia/mkclean/Makefile36
-rw-r--r--multimedia/mkclean/distinfo4
-rw-r--r--multimedia/mkclean/files/patch-corec__corec__helpers__file__file_libc.c11
-rw-r--r--multimedia/mkclean/files/patch-corec__corec__portab.h12
-rw-r--r--multimedia/mkclean/files/patch-file_libc.c11
-rw-r--r--multimedia/mkclean/pkg-descr13
6 files changed, 45 insertions, 42 deletions
diff --git a/multimedia/mkclean/Makefile b/multimedia/mkclean/Makefile
index 3828eb2e1b83..5c1536d75b67 100644
--- a/multimedia/mkclean/Makefile
+++ b/multimedia/mkclean/Makefile
@@ -6,34 +6,32 @@
#
PORTNAME= mkclean
-PORTVERSION= 0.6.0
+PORTVERSION= 0.8.6
CATEGORIES= multimedia
-MASTER_SITES= SF/matroska/${PORTNAME}
+MASTER_SITES= SF/matroska/${PORTNAME}/
-MAINTAINER= johnson.peter@gmail.com
+MAINTAINER= bapt@FreeBSD.org
COMMENT= Clean and optimize Matroska and WebM files
-USE_BZIP2= yes
-USE_ICONV= yes
-USE_GMAKE= yes
+LICENSE= BSD
+USE_BZIP2= yes
HAS_CONFIGURE= yes
-MAKE_ENV+= CCFLAGS="-I${LOCALBASE}/include" \
- LFLAGS="-L${LOCALBASE}/lib -liconv"
-MAKEFILE= GNUmakefile
+USE_GMAKE= yes
+USE_ICONV= yes
-PLIST_FILES= bin/mkclean bin/mkWDclean bin/mkvtree
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
-.include <bsd.port.pre.mk>
+MAKE_ENV+= "LFLAGS=${LDFLAGS}"
+MAKEFILE= GNUmakefile
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
-.if ${ARCH} == "sparc64"
-BROKEN= Does not configure on sparc64
-.endif
+PLIST_FILES= bin/mkclean
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/release/*/mkclean ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/release/*/mkWDclean ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/release/*/mkvtree ${PREFIX}/bin
+post-extract:
+ @${REINPLACE_CMD} -e "s,/usr/local,${PREFIX},g" ${WRKSRC}/corec/tools/coremake/gcc_mak.inc
+ @${RM} ${WRKSRC}/libmatroska2/test/test.proj
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/mkclean/distinfo b/multimedia/mkclean/distinfo
index ef32f3194cfc..97a64b11cc87 100644
--- a/multimedia/mkclean/distinfo
+++ b/multimedia/mkclean/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mkclean-0.6.0.tar.bz2) = 098f7a44c5aafde4a99d64dfccffb4404dc354874693acd05314d6a8c3c23245
-SIZE (mkclean-0.6.0.tar.bz2) = 718736
+SHA256 (mkclean-0.8.6.tar.bz2) = 6e81a7522ef47ddfefb4ae1f5d9bee217190741b6660f5240dba85bc4faf4a44
+SIZE (mkclean-0.8.6.tar.bz2) = 730851
diff --git a/multimedia/mkclean/files/patch-corec__corec__helpers__file__file_libc.c b/multimedia/mkclean/files/patch-corec__corec__helpers__file__file_libc.c
new file mode 100644
index 000000000000..b726b7608e2b
--- /dev/null
+++ b/multimedia/mkclean/files/patch-corec__corec__helpers__file__file_libc.c
@@ -0,0 +1,11 @@
+--- ./corec/corec/helpers/file/file_libc.c.orig 2011-09-25 11:25:46.000000000 +0200
++++ ./corec/corec/helpers/file/file_libc.c 2011-09-28 16:25:02.262950715 +0200
+@@ -40,7 +40,7 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <errno.h>
+-#if defined(TARGET_OSX)
++#if defined(TARGET_OSX) || defined(TARGET_FREEBSD)
+ #include <sys/mount.h>
+ #else
+ #include <sys/vfs.h>
diff --git a/multimedia/mkclean/files/patch-corec__corec__portab.h b/multimedia/mkclean/files/patch-corec__corec__portab.h
new file mode 100644
index 000000000000..8a1147a35f23
--- /dev/null
+++ b/multimedia/mkclean/files/patch-corec__corec__portab.h
@@ -0,0 +1,12 @@
+--- ./corec/corec/portab.h.orig 2011-09-25 11:25:46.000000000 +0200
++++ ./corec/corec/portab.h 2011-09-28 16:25:47.730826509 +0200
+@@ -159,6 +159,9 @@
+
+ #elif defined(__linux__) || defined(__CYGWIN__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+
++#if defined(__FreeBSD__)
++#define TARGET_FREEBSD
++#endif
+ #define TARGET_LINUX
+
+ #ifndef TARGET_QTOPIA // qtopia defines desktop manually
diff --git a/multimedia/mkclean/files/patch-file_libc.c b/multimedia/mkclean/files/patch-file_libc.c
deleted file mode 100644
index a2f26f8e0080..000000000000
--- a/multimedia/mkclean/files/patch-file_libc.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- corec/helpers/file/file_libc.c.orig 2010-09-26 04:42:30.000000000 -0700
-+++ corec/helpers/file/file_libc.c 2010-10-24 01:44:37.000000000 -0700
-@@ -40,7 +40,7 @@
- #include <unistd.h>
- #include <dirent.h>
- #include <errno.h>
--#if defined(TARGET_OSX)
-+#if defined(TARGET_OSX) || defined(__FreeBSD__)
- #include <sys/mount.h>
- #else
- #include <sys/vfs.h>
diff --git a/multimedia/mkclean/pkg-descr b/multimedia/mkclean/pkg-descr
index b35aa1d02e86..55857b292ed8 100644
--- a/multimedia/mkclean/pkg-descr
+++ b/multimedia/mkclean/pkg-descr
@@ -1,11 +1,4 @@
-mkclean is a command line tool to clean and optimize Matroska (.mkv / .mka /
-.mks) and WebM (.webm / .weba) files that have already been muxed. It reorders
-the elements with the Cues at the front, so your Matroska files are ready to be
-streamed efficiently over the web. It also removes elements not found in the
-Matroska specs and the extra Meta Seek list of Clusters that some program add
-to their file. It can also optionally remux the Cluster blocks to start each
-boundary with a keyframe and the matching audio/subtitle blocks for that
-keyframe.
+mkclean is a command line tool to clean and optimize Matroska files that have
+already been muxed.
-Also comes with mkWDclean to modify files in a way they can play in
-broken/incomplete players.
+WWW: http://www.matroska.org/downloads/mkclean.html