aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mkvtoolnix
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-02-25 19:36:31 +0800
committerJohn Marino <marino@FreeBSD.org>2015-02-25 19:36:31 +0800
commit52f0fabf1c6f601b02951d4f43501b7b31634053 (patch)
treec9172f2c28d2dd75eae7c69bcd771cc0db7add57 /multimedia/mkvtoolnix
parent728930e668bd6116dbfdd1b4b243aea45c66d046 (diff)
downloadfreebsd-ports-gnome-52f0fabf1c6f601b02951d4f43501b7b31634053.tar.gz
freebsd-ports-gnome-52f0fabf1c6f601b02951d4f43501b7b31634053.tar.zst
freebsd-ports-gnome-52f0fabf1c6f601b02951d4f43501b7b31634053.zip
multimedia/mkvtoolnix: set environment during build/install and unsuppress
This port was strange in that it not only failed to set the environment, it was unsetting PREFIX to whatever environment it had. This change sets the environment in both build and install targets with the exception of PREFIX. I don't know why that is done, but I maintained that part. While here, unsuppress the commands so that the build can be logged and change ";" to "&&" conjunctions which is preferred. Approved by: blanket
Diffstat (limited to 'multimedia/mkvtoolnix')
-rw-r--r--multimedia/mkvtoolnix/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index fb04749c3f2d..09abd4415074 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -59,9 +59,10 @@ INSTALLS_ICONS= yes
.endif
do-build:
- @(cd ${WRKSRC}/; unset PREFIX; ./drake ${_MAKE_JOBS})
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV:NPREFIX=*} ./drake ${_MAKE_JOBS})
do-install:
- @(cd ${WRKSRC}/; unset PREFIX; ./drake ${_MAKE_JOBS} ${MAKE_ARGS} install)
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV:NPREFIX=*} \
+ ./drake ${_MAKE_JOBS} ${MAKE_ARGS} install)
.include <bsd.port.mk>