aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/motion
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2008-05-21 01:33:29 +0800
committerlme <lme@FreeBSD.org>2008-05-21 01:33:29 +0800
commit0e7677e6905a66668de3232b9428bd1ac07c03af (patch)
tree438c189bfdd56fade49123d589c443423d49200a /multimedia/motion
parent1c51e2efb93ada720ca6fc4cd7a121d9eeb420d4 (diff)
downloadfreebsd-ports-gnome-0e7677e6905a66668de3232b9428bd1ac07c03af.tar.gz
freebsd-ports-gnome-0e7677e6905a66668de3232b9428bd1ac07c03af.tar.zst
freebsd-ports-gnome-0e7677e6905a66668de3232b9428bd1ac07c03af.zip
- Update to 3.2.10
- Enable support for PWCBSD-based Webcams - Install rc-script PR: ports/123808 Submitted by: Angel Carpintero <ack (AT) telefonica.net>
Diffstat (limited to 'multimedia/motion')
-rw-r--r--multimedia/motion/Makefile30
-rw-r--r--multimedia/motion/distinfo12
-rw-r--r--multimedia/motion/pkg-plist2
3 files changed, 30 insertions, 14 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index b815b0cd65d3..4ed7d6b07692 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= motion
-PORTVERSION= 3.2.9
-PORTREVISION= 1
+PORTVERSION= 3.2.10
CATEGORIES= multimedia
MASTER_SITES= SF
PATCH_SITES= http://www.lavrsen.dk/twiki/pub/Motion/FreeBSDPatch/
-PATCHFILES= motion-3.2.9-2.port-freebsd.diff.gz
+PATCHFILES= motion-3.2.10.port-freebsd.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= ack@telefonica.net
@@ -36,20 +35,27 @@ USE_GCC= 3.4+
MAN1= motion.1
PORTDOCS= CHANGELOG CREDITS README.FreeBSD README \
motion_guide.html
-EXAMPLES= motion-dist.conf motion.init-FreeBSD.sh thread1.conf \
- thread2.conf thread3.conf thread4.conf
+EXAMPLES= motion-dist.conf thread1.conf thread2.conf \
+ thread3.conf thread4.conf
-OPTIONS= BKTR "Support for TV Capture cards" on \
+OPTIONS= PWCBSD "PWCBSD based Webcams (disables BKTR)" off \
+ BKTR "Support for TV Capture cards" on \
LINUXTHREADS "Use LinuxThreads" off
MAKE_ENV+= CC="${CC}"
.include <bsd.port.pre.mk>
-.if !defined(WITH_BKTR)
+.if !defined(WITH_BKTR) && !defined(WITH_PWCBSD)
CFLAGS+= -DWITHOUT_V4L
.endif
+.if defined(WITH_PWCBSD)
+CONFIGURE_ARGS= --with-pwcbsd
+BUILD_DEPENDS+= v4l_compat>=1.0.20060801:${PORTSDIR}/multimedia/v4l_compat
+RUN_DEPENDS+= /boot/modules/pwc.ko:${PORTSDIR}/multimedia/pwcbsd
+.endif
+
.if defined(WITH_LINUXTHREADS) || ${OSVERSION} < 504000
CONFIGURE_ARGS= --with-linuxthreads
LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
@@ -59,10 +65,14 @@ post-install:
.if !exists(${PREFIX}/etc/motion.conf)
${INSTALL_DATA} ${PREFIX}/etc/motion.conf.sample ${PREFIX}/etc/motion.conf
.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.init-FreeBSD.sh ${PREFIX}/etc/rc.d/${PORTNAME}
${MKDIR} ${EXAMPLESDIR}
+
+.if !defined(NOPORTEXAMPLES)
.for f in ${EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
.endfor
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -77,4 +87,10 @@ post-install:
@${ECHO_MSG} "==============================================================================="
.endif
+.if defined(WITH_PWCBSD)
+ @${ECHO_MSG} "==============================================================================="
+ @${ECHO_MSG} "Please make sure you have pwcbsd compiled with mmap support."
+ @${ECHO_MSG} "==============================================================================="
+.endif
+
.include <bsd.port.post.mk>
diff --git a/multimedia/motion/distinfo b/multimedia/motion/distinfo
index b61040665284..a97aba3ae2e0 100644
--- a/multimedia/motion/distinfo
+++ b/multimedia/motion/distinfo
@@ -1,6 +1,6 @@
-MD5 (motion-3.2.9.tar.gz) = 6003011b126c9b17e23e085e7fba6536
-SHA256 (motion-3.2.9.tar.gz) = de452dc1530d078b29b5a39a909d7483c5b857df3f48c3cef73765a37e98f20c
-SIZE (motion-3.2.9.tar.gz) = 377075
-MD5 (motion-3.2.9-2.port-freebsd.diff.gz) = f3ddb2994d9bc7c54e3c89cf8a43fc6f
-SHA256 (motion-3.2.9-2.port-freebsd.diff.gz) = af6ef728d0734cf16d06f7a256eac007b5ec3db8f6baafb9e6caf9f1095f0e9f
-SIZE (motion-3.2.9-2.port-freebsd.diff.gz) = 4980
+MD5 (motion-3.2.10.tar.gz) = 8bbdfb794b8e55f0a7085c348381baa5
+SHA256 (motion-3.2.10.tar.gz) = ecebe3b9ab597aa906c64a4bf49eda9b9e24a20f8975146b34b4a69da3565e64
+SIZE (motion-3.2.10.tar.gz) = 402715
+MD5 (motion-3.2.10.port-freebsd.diff.gz) = 6ec2dae13d2d6821449c1520415d5975
+SHA256 (motion-3.2.10.port-freebsd.diff.gz) = 045b538b97f89ed5edb8d5067450169248128455c8d090f60671946e7975872d
+SIZE (motion-3.2.10.port-freebsd.diff.gz) = 2430
diff --git a/multimedia/motion/pkg-plist b/multimedia/motion/pkg-plist
index 6b2c971460df..614209873fb4 100644
--- a/multimedia/motion/pkg-plist
+++ b/multimedia/motion/pkg-plist
@@ -2,8 +2,8 @@ bin/motion
@unexec if cmp -s %D/etc/motion.conf %D/etc/motion.conf.sample; then rm -f %D/etc/motion.conf; fi
etc/motion.conf.sample
@exec [ -f %B/motion.conf ] || cp %B/%f %B/motion.conf
+etc/rc.d/motion
%%EXAMPLESDIR%%/motion-dist.conf
-%%EXAMPLESDIR%%/motion.init-FreeBSD.sh
%%EXAMPLESDIR%%/thread1.conf
%%EXAMPLESDIR%%/thread2.conf
%%EXAMPLESDIR%%/thread3.conf