aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mp4v2
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-03-14 10:10:35 +0800
committerahze <ahze@FreeBSD.org>2005-03-14 10:10:35 +0800
commit1c480e93acc84bdaf46ca79d8f6a7e29615be8de (patch)
treea247c6eb4a6def1580d0c316e602766a173523da /multimedia/mp4v2
parent1bdfa18e4180ee632920d5ab653c76eb514da39c (diff)
downloadfreebsd-ports-gnome-1c480e93acc84bdaf46ca79d8f6a7e29615be8de.tar.gz
freebsd-ports-gnome-1c480e93acc84bdaf46ca79d8f6a7e29615be8de.tar.zst
freebsd-ports-gnome-1c480e93acc84bdaf46ca79d8f6a7e29615be8de.zip
- Don't use gcc34 on 4.x by adding -O2 to CFLAGS
- Use USE_LIBTOOL_VER instead of USE_INC_LIBTOOL_VER since we don't have USE_GCC=3.4 anymore
Diffstat (limited to 'multimedia/mp4v2')
-rw-r--r--multimedia/mp4v2/Makefile6
-rw-r--r--multimedia/mp4v2/files/patch-ltmain.sh15
2 files changed, 3 insertions, 18 deletions
diff --git a/multimedia/mp4v2/Makefile b/multimedia/mp4v2/Makefile
index 67493f34a88c..0630d2c257bc 100644
--- a/multimedia/mp4v2/Makefile
+++ b/multimedia/mp4v2/Makefile
@@ -18,7 +18,7 @@ COMMENT= Mpeg-4 library and tools from mpeg4ip
USE_GMAKE= yes
USE_GNOME= gnometarget
-USE_INC_LIBTOOL_VER=15
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
@@ -33,8 +33,8 @@ INSTALL_WRKSRC= ${WRKSRC}/lib/mp4v2
BROKEN= "Please remove older version of faad before attempting to build ${PORTNAME}"
.endif
-.if ${OSVERSION} < 502110
-USE_GCC= 3.4
+.if ${OSVERSION} < 500000
+CFLAGS+= -O2
.endif
post-patch:
diff --git a/multimedia/mp4v2/files/patch-ltmain.sh b/multimedia/mp4v2/files/patch-ltmain.sh
deleted file mode 100644
index b7b985b46652..000000000000
--- a/multimedia/mp4v2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Sep 30 04:09:46 2004
-+++ ltmain.sh Thu Sep 30 04:11:06 2004
-@@ -5425,10 +5425,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"