aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mpeg_encode
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /multimedia/mpeg_encode
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'multimedia/mpeg_encode')
-rw-r--r--multimedia/mpeg_encode/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/multimedia/mpeg_encode/Makefile b/multimedia/mpeg_encode/Makefile
index 2c580cf3887e..65d97cc0df93 100644
--- a/multimedia/mpeg_encode/Makefile
+++ b/multimedia/mpeg_encode/Makefile
@@ -15,11 +15,13 @@ MAINTAINER= ports@FreeBSD.org
MAN1= mpeg_encode.1
+USE_REINPLACE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
post-patch:
@(${GREP} -R -l "malloc.h" ${WRKSRC}/* | \
- ${XARGS} ${PERL} -pi -e "s/malloc.h/stdlib.h/")
+ ${XARGS} ${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/")
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mpeg_encode ${PREFIX}/bin