aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-09-26 03:13:40 +0800
committerlioux <lioux@FreeBSD.org>2002-09-26 03:13:40 +0800
commit22d4bb7f9714ba1324dff8198460e6e0fd632712 (patch)
tree879bf0c35107e4dae5aec5df93e2a57d14d09e89 /multimedia/mplayer
parent419a5eb7da9f3108e91586bc831d9ec699360537 (diff)
downloadfreebsd-ports-gnome-22d4bb7f9714ba1324dff8198460e6e0fd632712.tar.gz
freebsd-ports-gnome-22d4bb7f9714ba1324dff8198460e6e0fd632712.tar.zst
freebsd-ports-gnome-22d4bb7f9714ba1324dff8198460e6e0fd632712.zip
o Add WITH_REALPLAYER support plus autodetection so that a correct
port dependency is built [1] o Have WITH_LIBDVDREAD really work [2] PR: 43291 [1] Submitted by: alane [1], MAINTAINER [2] Approved by: maintainer
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 8d758bf4048d..4a8daeac4d3c 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mplayer
PORTVERSION= 0.90.0.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
@@ -74,6 +75,10 @@ LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
WITH_XANIM= yes
.endif
+.if exists(${LOCALBASE}/lib/RealPlayer8/realplay)
+WITH_REALPLAYER= yes
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
@@ -111,6 +116,13 @@ LIB_DEPENDS+= SDL-1.1.4:${PORTSDIR}/devel/sdl12
LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
.endif
+.if defined(WITH_REALPLAYER)
+CONFIGURE_ARGS+= --enable-real \
+ --with-reallibdir=${LOCALBASE}/lib/RealPlayer8/Codecs
+RUN_DEPENDS+= realplay:${PORTSDIR}/audio/linux-realplayer
+BUILD_DEPENDS+= realplay:${PORTSDIR}/audio/linux-realplayer
+.endif
+
.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/graphics/xanim
@@ -192,6 +204,10 @@ pre-everything::
.if !defined(WITHOUT_WIN32_CODECS)
@${ECHO_MSG} "You can disable support (this turns this into a X86 only port)"
@${ECHO_MSG} "for Win32 codecs by defining WITHOUT_WIN32_CODECS"
+.if !defined(WITH_REALPLAYER)
+ @${ECHO_MSG} \
+ "You can enable RealPlayer DLL support by defining WITH_REALPLAYER."
+.endif
.endif
.if defined(WITHOUT_RUNTIME_CPUDETECTION)
.if !defined(WITHOUT_SSE)
@@ -216,7 +232,7 @@ pre-everything::
pre-configure:
.if defined(WITH_LIBDVDREAD)
- @${RM} -Rf ${WRKSRC}/libmpdvdkit/
+ @${RM} -Rf ${WRKSRC}/libmpdvdkit2/
.endif
post-install: