aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2007-01-09 00:02:14 +0800
committeritetcu <itetcu@FreeBSD.org>2007-01-09 00:02:14 +0800
commitd09769bc901461f0e8edd8ef4e22a780b65b0ee2 (patch)
tree5176bfe19dc61dc52f8a22e5058c4147a6cacfdb /multimedia/mplayer
parent2f95162b4017699855151911c4d81d1f07dbc584 (diff)
downloadfreebsd-ports-gnome-d09769bc901461f0e8edd8ef4e22a780b65b0ee2.tar.gz
freebsd-ports-gnome-d09769bc901461f0e8edd8ef4e22a780b65b0ee2.tar.zst
freebsd-ports-gnome-d09769bc901461f0e8edd8ef4e22a780b65b0ee2.zip
- fix build of mplayer with h264 and polyaudio, when an external reference was
generated to: last_coeff_flag_offset in the polyaudio module, that is static in the h264. - security fix provided by the mplayer development team for a possible remote buffer overflow in rtsp streams - Correct library dependence and OPTIONS for samba support PR: ports/107217 Submitted by: Sergio Lenzi [1], Thomas E. Zander (maintainer) [2] Approved by: maintainer Security: http://www.vuxml.org/freebsd/b2ff68b2-9f29-11db-a4e4-0211d87675b7.hml
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile13
-rw-r--r--multimedia/mplayer/distinfo3
-rw-r--r--multimedia/mplayer/files/patch-libavcodec-h264.c11
3 files changed, 26 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 79101ef5ac83..0fc4724bf008 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -84,7 +84,7 @@
PORTNAME= mplayer
PORTVERSION= 0.99.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -101,6 +101,9 @@ DISTNAME= MPlayer-1.0rc1
MAINTAINER= riggs@rrr.de
COMMENT= High performance media player/encoder supporting many formats
+PATCH_SITES= http://www.mplayerhq.hu/MPlayer/patches/
+PATCHFILES+= asmrules_fix_20061231.diff
+
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
@@ -165,6 +168,7 @@ OPTIONS+= XANIM "Enable xanim DLL support" off
OPTIONS+= XVID "Enable XVID video codec support" on
OPTIONS+= REALPLAYER "Enable real player plugin" off
OPTIONS+= LIVEMEDIA "Enable LIVE555 streaming support" off
+OPTIONS+= SMB "Enable Samba input support" off
OPTIONS+= FRIBIDI "Enable FriBiDi support" off
OPTIONS+= LIRC "Enable lirc support" off
OPTIONS+= LIBCDIO "Enable libcdio support" off
@@ -471,6 +475,13 @@ BUILD_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/live
CONFIGURE_ARGS+= --disable-live
.endif
+.if defined(WITH_SMB)
+CONFIGURE_ARGS+= --enable-smb
+LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+.else
+CONFIGURE_ARGS+= --disable-smb
+.endif
+
.if !defined(WITHOUT_XVID)
CONFIGURE_ARGS+= --enable-xvid
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index bd09730976f0..ce7f15a5afc1 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,3 +1,6 @@
MD5 (MPlayer-1.0rc1.tar.bz2) = 18c05d88e22c3b815a43ca8d7152ccdc
SHA256 (MPlayer-1.0rc1.tar.bz2) = 8dd9dd61a0fe56904f5b76ddedb99bd359abaaf486e0b83b45e3357fecc81063
SIZE (MPlayer-1.0rc1.tar.bz2) = 8414213
+MD5 (asmrules_fix_20061231.diff) = f0b71c38b1207c1d604be091876ac051
+SHA256 (asmrules_fix_20061231.diff) = 3f71e6f4e07940d4d55084d0df12404371bc4e534a3a6b0756ca73e44ddbc3c4
+SIZE (asmrules_fix_20061231.diff) = 1450
diff --git a/multimedia/mplayer/files/patch-libavcodec-h264.c b/multimedia/mplayer/files/patch-libavcodec-h264.c
new file mode 100644
index 000000000000..371bf01eaef8
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libavcodec-h264.c
@@ -0,0 +1,11 @@
+--- libavcodec/h264.c.orig Thu Dec 21 14:57:54 2006
++++ libavcodec/h264.c Thu Dec 21 15:00:14 2006
+@@ -6034,7 +6034,7 @@
+ return ctx + 4 * cat;
+ }
+
+-static const __attribute((used)) uint8_t last_coeff_flag_offset_8x8[63] = {
++const __attribute((used)) uint8_t last_coeff_flag_offset_8x8[63] = {
+ 0, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
+ 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2,
+ 3, 3, 3, 3, 3, 3, 3, 3, 4, 4, 4, 4, 4, 4, 4, 4,