aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/obs-studio
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-12-31 01:45:32 +0800
committerrakuco <rakuco@FreeBSD.org>2015-12-31 01:45:32 +0800
commit9e393f4b3db656d0acb466d9fa3f9888cb501ddc (patch)
treeeee5b882c5b82c2ca4dc978b8c472738369c1655 /multimedia/obs-studio
parentd17a363e6665033194d363b3fe95be83bb36c24e (diff)
downloadfreebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.tar.gz
freebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.tar.zst
freebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.zip
Finish fixing broken ports after r404856 and r404694.
* multimedia/obs-studio: Import some upstream commits that pass all required include directories to the compiler and reference libsysinfo.so with a full path instead of passing -lsysinfo and relying on ${LOCALBASE}/lib being in the linker search path. * textproc/sigil: Pass LDFLAGS+=${LOCALBASE}/lib for now to work around the fact that upstream's build system references libhunspell-1.3.so and libpcre16.so without full paths (instead of finding them with the proper CMake commands it relies on pkg-config's output). * x11/antimicro: Also pass LDFLAGS+=${LOCALBASE}/lib for now to work around the fact that several X11 and SDL2 libraries are referenced without full paths. I sent a pull request upstream to fix the X11 references, but SDL2 is still detected through pkg-config. MFH: 2015Q4
Diffstat (limited to 'multimedia/obs-studio')
-rw-r--r--multimedia/obs-studio/Makefile2
-rw-r--r--multimedia/obs-studio/files/patch-git_4bdb45a825
-rw-r--r--multimedia/obs-studio/files/patch-git_5983b50625
3 files changed, 51 insertions, 1 deletions
diff --git a/multimedia/obs-studio/Makefile b/multimedia/obs-studio/Makefile
index b3319a1c2d2f..e6598b88ed15 100644
--- a/multimedia/obs-studio/Makefile
+++ b/multimedia/obs-studio/Makefile
@@ -27,7 +27,7 @@ USE_GL+= gl
USE_QT5= core dbus gui opengl network svg multimedia \
imageformats buildtools qmake x11extras
CFLAGS+= -fPIC
-LDFLAGS+= -lsysinfo
+LDFLAGS+= ${LOCALBASE}/lib/libsysinfo.so
USES= cmake compiler:c11
CMAKE_ARGS+= -DUNIX_STRUCTURE=1 \
-DOBS_VERSION_OVERRIDE=${PORTVERSION}
diff --git a/multimedia/obs-studio/files/patch-git_4bdb45a8 b/multimedia/obs-studio/files/patch-git_4bdb45a8
new file mode 100644
index 000000000000..72cab0cf7761
--- /dev/null
+++ b/multimedia/obs-studio/files/patch-git_4bdb45a8
@@ -0,0 +1,25 @@
+commit 4bdb45a8acfee805c715ca8ccf3cf74aac1a5223
+Author: fryshorts <leonhard@in-verted.de>
+Date: Sun May 3 17:09:29 2015 +0200
+
+ linux-v4l2: Add include directory to cmake
+
+ Add the include directories found by cmake to the v4l2 plugin.
+ This allows for the plugin to compile when the vl42 headers were
+ found in a directory that is not normally in the search path of the
+ compiler (e.g. /usr/local/include)
+
+--- plugins/linux-v4l2/CMakeLists.txt
++++ plugins/linux-v4l2/CMakeLists.txt
+@@ -24,6 +24,11 @@ else()
+ add_definitions(-DHAVE_UDEV)
+ endif()
+
++include_directories(
++ SYSTEM "${CMAKE_SOURCE_DIR}/libobs"
++ ${LIBV4L2_INCLUDE_DIRS}
++)
++
+ set(linux-v4l2_SOURCES
+ linux-v4l2.c
+ v4l2-input.c
diff --git a/multimedia/obs-studio/files/patch-git_5983b506 b/multimedia/obs-studio/files/patch-git_5983b506
new file mode 100644
index 000000000000..f1e095d42566
--- /dev/null
+++ b/multimedia/obs-studio/files/patch-git_5983b506
@@ -0,0 +1,25 @@
+commit 5983b506e9a692a00987d86a60390028d3ad73ce
+Author: fryshorts <leonhard@in-verted.de>
+Date: Sun May 3 17:01:09 2015 +0200
+
+ linux-pulseaudio: Add include directory to cmake
+
+ Add the include directories found by cmake to the pulseaudio plugin.
+ This allows for the plugin to compile when the pulseaudio headers were
+ found in a directory that is not normally in the search path of the
+ compiler (e.g. /usr/local/include)
+
+--- plugins/linux-pulseaudio/CMakeLists.txt
++++ plugins/linux-pulseaudio/CMakeLists.txt
+@@ -13,7 +13,10 @@ elseif(NOT PULSEAUDIO_FOUND)
+ return()
+ endif()
+
+-include_directories(SYSTEM "${CMAKE_SOURCE_DIR}/libobs")
++include_directories(
++ SYSTEM "${CMAKE_SOURCE_DIR}/libobs"
++ ${PULSEAUDIO_INCLUDE_DIR}
++)
+
+ set(linux-pulseaudio_SOURCES
+ linux-pulseaudio.c