aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/pvr250/files
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-10-15 20:12:15 +0800
committeredwin <edwin@FreeBSD.org>2004-10-15 20:12:15 +0800
commit70f15ed6d19caba96fb847de376f46c857086498 (patch)
tree6f0d6cca2ed8a7884919fefb608bad92cbef94a0 /multimedia/pvr250/files
parentf3e9752971e4081c8abc0d2c19d3120c1317313b (diff)
downloadfreebsd-ports-gnome-70f15ed6d19caba96fb847de376f46c857086498.tar.gz
freebsd-ports-gnome-70f15ed6d19caba96fb847de376f46c857086498.tar.zst
freebsd-ports-gnome-70f15ed6d19caba96fb847de376f46c857086498.zip
Submit a lkm for the cxm device, found in the Hauppauge PVR-250/350
TV cards. This port contains: - Drivers for the Conexant MPEG-2 Codec driver which can be found on the Hauppauge PVR-250/350 TV cards. These drivers are (c) John Wehle <john@feith.com> On FreeBSD 4.x, the device used is /dev/bktr0. On FreeBSD 5.x, the device used is /dev/cxm0 This driver has been successfully tested on: - FreeBSD 4.10 - FreeBSD 5.2.1 - Two simple programs to modify some ioctls on the card: set the channel and set the window size. Note: - The configuration screen is only applicable for the the Philips FQ1216M tuner. For other tuners ignore this section. Select just one entry. - Note: the maintainer of this port has no inside knowledge of the workings of this software. Please don't contact me about cards which don't work. Please contact me about problems with the port, with possible enhancements, with success stories. Author: John Wehle <john@feith.com> Submitted by: edwin@mavetju.org
Diffstat (limited to 'multimedia/pvr250/files')
-rw-r--r--multimedia/pvr250/files/patch-modules::cxm::cxm::Makefile9
-rw-r--r--multimedia/pvr250/files/patch-modules::cxm::cxm_iic::Makefile9
-rw-r--r--multimedia/pvr250/files/patchtuner-bgaustralia11
-rw-r--r--multimedia/pvr250/files/patchtuner-bgbroadcast11
-rw-r--r--multimedia/pvr250/files/patchtuner-ibroadcast11
-rw-r--r--multimedia/pvr250/files/patchtuner-lbroadcast11
-rw-r--r--multimedia/pvr250/files/patchtuner-usbroadcast11
-rw-r--r--multimedia/pvr250/files/patchtuner-uscable11
8 files changed, 84 insertions, 0 deletions
diff --git a/multimedia/pvr250/files/patch-modules::cxm::cxm::Makefile b/multimedia/pvr250/files/patch-modules::cxm::cxm::Makefile
new file mode 100644
index 000000000000..b06e1e1445f7
--- /dev/null
+++ b/multimedia/pvr250/files/patch-modules::cxm::cxm::Makefile
@@ -0,0 +1,9 @@
+--- modules/cxm/cxm/Makefile.orig Fri Oct 15 20:53:47 2004
++++ modules/cxm/cxm/Makefile Fri Oct 15 20:55:03 2004
+@@ -3,5 +3,6 @@
+ SRCS = cxm.c cxm.h cxm_dec_fw.c cxm_enc_fw.c cxm_audio.c cxm_eeprom.c \
+ cxm_ir.c cxm_tuner.c cxm_video.c opt_cxm.h \
+ bus_if.h device_if.h iicbb_if.h pci_if.h vnode_if.h
++CFLAGS+= -I../../..
+
+ .include <bsd.kmod.mk>
diff --git a/multimedia/pvr250/files/patch-modules::cxm::cxm_iic::Makefile b/multimedia/pvr250/files/patch-modules::cxm::cxm_iic::Makefile
new file mode 100644
index 000000000000..8fd5589aa033
--- /dev/null
+++ b/multimedia/pvr250/files/patch-modules::cxm::cxm_iic::Makefile
@@ -0,0 +1,9 @@
+--- modules/cxm/cxm_iic/Makefile.orig Fri Oct 15 20:55:23 2004
++++ modules/cxm/cxm_iic/Makefile Fri Oct 15 20:55:43 2004
+@@ -2,5 +2,6 @@
+ KMOD = cxm_iic
+ SRCS = cxm_i2c.c cxm.h \
+ opt_cxm.h bus_if.h device_if.h iicbb_if.h pci_if.h
++CFLAGS += -I../../..
+
+ .include <bsd.kmod.mk>
diff --git a/multimedia/pvr250/files/patchtuner-bgaustralia b/multimedia/pvr250/files/patchtuner-bgaustralia
new file mode 100644
index 000000000000..ced226ac7e7d
--- /dev/null
+++ b/multimedia/pvr250/files/patchtuner-bgaustralia
@@ -0,0 +1,11 @@
+--- dev/cxm/cxm_tuner.c.org Fri Oct 15 21:31:06 2004
++++ dev/cxm/cxm_tuner.c Fri Oct 15 21:31:24 2004
+@@ -227,7 +227,7 @@
+ { 48250, { 0x8e, 0xa0 } } },
+ 0, 0,
+ { 0 },
+- { &l_air_channels, NULL } },
++ { &bg_australia_channels, NULL } },
+ { "Philips FI1236 MK2",
+ CXM_TUNER_TV_SYSTEM_MN,
+ { { 0 }, { 0 }, { 0 }, { 0 }, { 0 } },
diff --git a/multimedia/pvr250/files/patchtuner-bgbroadcast b/multimedia/pvr250/files/patchtuner-bgbroadcast
new file mode 100644
index 000000000000..fe56272487bd
--- /dev/null
+++ b/multimedia/pvr250/files/patchtuner-bgbroadcast
@@ -0,0 +1,11 @@
+--- dev/cxm/cxm_tuner.c.org Fri Oct 15 21:31:06 2004
++++ dev/cxm/cxm_tuner.c Fri Oct 15 21:31:24 2004
+@@ -227,7 +227,7 @@
+ { 48250, { 0x8e, 0xa0 } } },
+ 0, 0,
+ { 0 },
+- { &l_air_channels, NULL } },
++ { &bg_air_channels, NULL } },
+ { "Philips FI1236 MK2",
+ CXM_TUNER_TV_SYSTEM_MN,
+ { { 0 }, { 0 }, { 0 }, { 0 }, { 0 } },
diff --git a/multimedia/pvr250/files/patchtuner-ibroadcast b/multimedia/pvr250/files/patchtuner-ibroadcast
new file mode 100644
index 000000000000..a849446ea525
--- /dev/null
+++ b/multimedia/pvr250/files/patchtuner-ibroadcast
@@ -0,0 +1,11 @@
+--- dev/cxm/cxm_tuner.c.org Fri Oct 15 21:31:06 2004
++++ dev/cxm/cxm_tuner.c Fri Oct 15 21:31:24 2004
+@@ -227,7 +227,7 @@
+ { 48250, { 0x8e, 0xa0 } } },
+ 0, 0,
+ { 0 },
+- { &l_air_channels, NULL } },
++ { &i_air_channels, NULL } },
+ { "Philips FI1236 MK2",
+ CXM_TUNER_TV_SYSTEM_MN,
+ { { 0 }, { 0 }, { 0 }, { 0 }, { 0 } },
diff --git a/multimedia/pvr250/files/patchtuner-lbroadcast b/multimedia/pvr250/files/patchtuner-lbroadcast
new file mode 100644
index 000000000000..62481031b8ca
--- /dev/null
+++ b/multimedia/pvr250/files/patchtuner-lbroadcast
@@ -0,0 +1,11 @@
+--- dev/cxm/cxm_tuner.c.org Fri Oct 15 21:31:06 2004
++++ dev/cxm/cxm_tuner.c Fri Oct 15 21:31:24 2004
+@@ -227,7 +227,7 @@
+ { 48250, { 0x8e, 0xa0 } } },
+ 0, 0,
+ { 0 },
+- { &l_air_channels, NULL } },
++ { &l_air_channels, NULL } },
+ { "Philips FI1236 MK2",
+ CXM_TUNER_TV_SYSTEM_MN,
+ { { 0 }, { 0 }, { 0 }, { 0 }, { 0 } },
diff --git a/multimedia/pvr250/files/patchtuner-usbroadcast b/multimedia/pvr250/files/patchtuner-usbroadcast
new file mode 100644
index 000000000000..6ed81cd14d43
--- /dev/null
+++ b/multimedia/pvr250/files/patchtuner-usbroadcast
@@ -0,0 +1,11 @@
+--- dev/cxm/cxm_tuner.c.org Fri Oct 15 21:31:06 2004
++++ dev/cxm/cxm_tuner.c Fri Oct 15 21:31:24 2004
+@@ -227,7 +227,7 @@
+ { 48250, { 0x8e, 0xa0 } } },
+ 0, 0,
+ { 0 },
+- { &l_air_channels, NULL } },
++ { &us_air_channels, NULL } },
+ { "Philips FI1236 MK2",
+ CXM_TUNER_TV_SYSTEM_MN,
+ { { 0 }, { 0 }, { 0 }, { 0 }, { 0 } },
diff --git a/multimedia/pvr250/files/patchtuner-uscable b/multimedia/pvr250/files/patchtuner-uscable
new file mode 100644
index 000000000000..7efe23a85125
--- /dev/null
+++ b/multimedia/pvr250/files/patchtuner-uscable
@@ -0,0 +1,11 @@
+--- dev/cxm/cxm_tuner.c.org Fri Oct 15 21:31:06 2004
++++ dev/cxm/cxm_tuner.c Fri Oct 15 21:31:24 2004
+@@ -227,7 +227,7 @@
+ { 48250, { 0x8e, 0xa0 } } },
+ 0, 0,
+ { 0 },
+- { &l_air_channels, NULL } },
++ { &us_cable_channels, NULL } },
+ { "Philips FI1236 MK2",
+ CXM_TUNER_TV_SYSTEM_MN,
+ { { 0 }, { 0 }, { 0 }, { 0 }, { 0 } },