aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/sabbu
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2019-06-03 17:19:00 +0800
committerdinoex <dinoex@FreeBSD.org>2019-06-03 17:19:00 +0800
commit1f82ff3131d87f6755a6ab3cf1c37f0d770ce669 (patch)
treef5668e08a94557731eaeaafc8c130d07343fa579 /multimedia/sabbu
parent7d22965de61829e2d75ea164d01d60225feb65c2 (diff)
downloadfreebsd-ports-gnome-1f82ff3131d87f6755a6ab3cf1c37f0d770ce669.tar.gz
freebsd-ports-gnome-1f82ff3131d87f6755a6ab3cf1c37f0d770ce669.tar.zst
freebsd-ports-gnome-1f82ff3131d87f6755a6ab3cf1c37f0d770ce669.zip
- drop dependency on multimedia/ffmpeg0
PR: 238094
Diffstat (limited to 'multimedia/sabbu')
-rw-r--r--multimedia/sabbu/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index 237fd79b3f35..5909112ab2d1 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sabbu
PORTVERSION= 0.3.0
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Sabbu%20${PORTVERSION}
@@ -11,18 +11,18 @@ COMMENT= Program used to time subtitles
LICENSE= GPLv2
-LIB_DEPENDS= libavcodec0.so:multimedia/ffmpeg0 \
- libsndfile.so:audio/libsndfile
+LIB_DEPENDS= libsndfile.so:audio/libsndfile
-USES= compiler:c++11-lang tar:bzip2 gmake pkgconfig iconv
+USES= tar:bzip2 gmake compiler:c++11-lang pkgconfig iconv
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-ffmpeg
USE_SDL= sdl
USE_CXXSTD= gnu++98
USE_GNOME= gtk20
-CFLAGS+= -I${LOCALBASE}/include/ffmpeg0 -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib/ffmpeg0 -L${LOCALBASE}/lib
-LDFLAGS+= -lswscale0 -lgmodule-2.0
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+LDFLAGS+= -lgmodule-2.0
OPTIONS_DEFINE= GTKSPELL NLS
OPTIONS_DEFAULT=GTKSPELL
@@ -39,12 +39,4 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= WITH_NLS="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} \
- -e 's,ffmpeg/avformat,libavformat/avformat,g' \
- -e 's,lavcodec,lavcodec0,g' \
- -e 's,lavformat,lavformat0,g' \
- -e '/FFMPEG_LIBS=/s/"$$/ -lavutil0"/' \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>