aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/totem/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /multimedia/totem/Makefile
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadfreebsd-ports-gnome-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
freebsd-ports-gnome-e18151212d3326dbf04797c6d5300fb1211ee875.tar.zst
freebsd-ports-gnome-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'multimedia/totem/Makefile')
-rw-r--r--multimedia/totem/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 7219abe9e3ef..d7afe69d99ae 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= totem
-PORTVERSION= 1.0.4
-PORTREVISION?= 1
+PORTVERSION= 1.2.0
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -23,7 +22,7 @@ USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils \
nautiluscdburner
WANT_GSTREAMER= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -36,11 +35,15 @@ OPTIONS?= DVDNAV "Enable DVD support" on \
MAN1= totem.1 totem-video-thumbnailer.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
totem.schemas
-CONFLICTS?= totem-gstreamer-[0-9]*
+CONFLICTS= totem-gstreamer-[0-9]*
.include <bsd.port.pre.mk>
+LIB_DEPENDS+= musicbrainz:${PORTSDIR}/audio/libmusicbrainz
+
.if defined(WITH_GSTREAMER)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
CONFIGURE_ARGS+=--enable-gstreamer
USE_GSTREAMER+= gnomevfs core gconf
WITHOUT_DVDNAV= yes
@@ -86,13 +89,11 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
${WRKSRC}/src/totem-preferences.c \
- ${WRKSRC}/src/bacon-video-widget-gst.c
+ ${WRKSRC}/src/backend/bacon-video-widget-gst.c
.if defined(WITH_GSTREAMER)
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
- ${WRKSRC}/src/bacon-video-widget-gst.c
+ ${WRKSRC}/src/backend/bacon-video-widget-gst.c
.endif
- @${REINPLACE_CMD} -e 's|@LOCALBASE@|${LOCALBASE}|' \
- ${WRKSRC}/src/bacon-video-widget-xine.c
post-install:
@-update-desktop-database