aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/transcode
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
committeredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
commit5d87bf6f020ae3177a26e679d65b5e50f035bbe1 (patch)
treeca9d8a7830bc4c19ec29804b066fc99d81d7488b /multimedia/transcode
parent476102ca837a76b18c930b013cb486ec3f0ce79e (diff)
downloadfreebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.gz
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.zst
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'multimedia/transcode')
-rw-r--r--multimedia/transcode/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 2f1734c27948..0e50f055eb23 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -29,6 +29,7 @@ CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
+WANT_SDL= yes
MAN1= avifix.1 aviindex.1 avimerge.1 avisplit.1 avisync.1 tccat.1 tcdemux.1 \
tcprobe.1 tcscan.1 transcode.1 tcextract.1 tcdecode.1 tcmodinfo.1 \
@@ -48,7 +49,7 @@ WITH_IMAGEMAGICK= yes
WITH_AVIFILE= yes
.endif
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
@@ -138,7 +139,7 @@ WITHOUT_FFMPEG= YES
.endif
.if defined(WITH_SDL)
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+USE_SDL= sdl
WITH_LIBDV= yes
PLIST_SUB+= WITH_SDL=""
.else