aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vdr-plugin-infosatepg/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2017-02-08 15:45:16 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-02-08 15:45:16 +0800
commit8c10568a8bad15bd4e148e5298d61c75faa3c30d (patch)
tree8ec8a8ad03e47a7286399402357b1c326bf89c9d /multimedia/vdr-plugin-infosatepg/Makefile
parentccabcd384d766804d3ce54b6a7ae1d257ce0fc11 (diff)
parent39324c127c7b2461bbbbbb06c5dd94442e997b46 (diff)
downloadfreebsd-ports-gnome-mate-1.16.tar.gz
freebsd-ports-gnome-mate-1.16.tar.zst
freebsd-ports-gnome-mate-1.16.zip
Merge branch 'master' into mate-1.16mate-1.16
Diffstat (limited to 'multimedia/vdr-plugin-infosatepg/Makefile')
-rw-r--r--multimedia/vdr-plugin-infosatepg/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/multimedia/vdr-plugin-infosatepg/Makefile b/multimedia/vdr-plugin-infosatepg/Makefile
index 88a86d8e887f..fb8af6285ec5 100644
--- a/multimedia/vdr-plugin-infosatepg/Makefile
+++ b/multimedia/vdr-plugin-infosatepg/Makefile
@@ -11,22 +11,29 @@ DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERS
MAINTAINER= ports@FreeBSD.org
COMMENT= Video Disk Recorder - infosat EPG plugin
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= tar:tgz
PATCH_STRIP= -p1
-HAVE_CONFIGURE= yes
-PORTDOCS= COPYING README HISTORY
WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION}
+PORTDOCS= README HISTORY
+
+OPTIONS_DEFINE= DOCS NLS
+
.include "${.CURDIR}/../vdr/Makefile.plugins"
post-patch: post-patch-plugin
pre-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/vdr
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/vdr
post-install: post-install-pluginlocales
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}/var/cache/vdr/${PLUGIN}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
- ${MKDIR} ${STAGEDIR}/var/cache/vdr/${PLUGIN}
.include <bsd.port.mk>