aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vlc
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2012-09-04 04:32:26 +0800
committernox <nox@FreeBSD.org>2012-09-04 04:32:26 +0800
commit395ded1ebd7ffe71509bdf7ef2cce30e25051b2d (patch)
treedd4e11c53c62d64fe6053a847503140b78838f7b /multimedia/vlc
parentc57a90b2fa8af538ba6b04a15389b32936e02780 (diff)
downloadfreebsd-ports-gnome-395ded1ebd7ffe71509bdf7ef2cce30e25051b2d.tar.gz
freebsd-ports-gnome-395ded1ebd7ffe71509bdf7ef2cce30e25051b2d.tar.zst
freebsd-ports-gnome-395ded1ebd7ffe71509bdf7ef2cce30e25051b2d.zip
- Fix remaining i386 build failures by setting USE_GCC?= 4.6+ there, see:
http://trac.videolan.org/vlc/ticket/5979 - Remove bogus patch reference to fix build with UPNP knob - there are still runtime crashes tho due to devel/upnp picking up the wrong uuid_create(), see my patch here: http://docs.freebsd.org/cgi/mid.cgi?20120903194543.GA38349 - Pet portlint.
Diffstat (limited to 'multimedia/vlc')
-rw-r--r--multimedia/vlc/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index d02a61d651c8..43cf2fa6097d 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -13,7 +13,6 @@ CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/p/-pre/}/ \
http://ftp.snt.utwente.nl/pub/software/videolan/${PORTNAME}/${DISTVERSION}/ \
ftp://ftp.crans.org/pub/videolan/${PORTNAME}/${DISTVERSION}/
-DISTNAME= ${PORTNAME}-${DISTVERSION:S/p/-pre/}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Qt4 based multimedia player and streaming server
@@ -194,9 +193,8 @@ IGNORE= base clang version too old, set NO_IGNORE to override
CONFIGURE_ARGS+=--enable-altivec # VLC's config script doesn't know to do this
.endif
-# sometimes(?) misdetected causing build failure
.if ${ARCH} == "i386"
-CONFIGURE_ARGS+=--disable-sse --disable-mmx
+USE_GCC?= 4.6+ # sse/3dnow detection on i386 needs newer gcc
.endif
# End OS specific hacks
@@ -610,7 +608,6 @@ CONFIGURE_ARGS+= --disable-twolame
.if ${PORT_OPTIONS:MUPNP}
LIB_DEPENDS+= upnp:${PORTSDIR}/devel/upnp
CONFIGURE_ARGS+=--enable-upnp
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-modules__services_discovery__upnp_intel.cpp
.else
CONFIGURE_ARGS+=--disable-upnp
.endif