aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vtkmpeg2encode
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2008-01-10 04:08:58 +0800
committerthierry <thierry@FreeBSD.org>2008-01-10 04:08:58 +0800
commit1b89ba513705afa4e197875f634b6eeb9c18ce01 (patch)
tree4a0d13f1273d253c620f8fd25037a7bedc9d74fc /multimedia/vtkmpeg2encode
parent5b0b353ac594f2d098ff308fd29d98764d5069c1 (diff)
downloadfreebsd-ports-gnome-1b89ba513705afa4e197875f634b6eeb9c18ce01.tar.gz
freebsd-ports-gnome-1b89ba513705afa4e197875f634b6eeb9c18ce01.tar.zst
freebsd-ports-gnome-1b89ba513705afa4e197875f634b6eeb9c18ce01.zip
This is the VTK MPEG2 encoder library, which has been removed from the
main VTK distribution due to MPEG patent issues. This port is an optional dependency for the new vtk5 port. PR: ports/119082 Submitted by: Jason W. Bacon <bacon (at) smithers.neuro.mcw.edu>
Diffstat (limited to 'multimedia/vtkmpeg2encode')
-rw-r--r--multimedia/vtkmpeg2encode/Makefile75
-rw-r--r--multimedia/vtkmpeg2encode/distinfo3
-rw-r--r--multimedia/vtkmpeg2encode/files/vtkmpeg2encode.3.in50
-rw-r--r--multimedia/vtkmpeg2encode/pkg-descr3
-rw-r--r--multimedia/vtkmpeg2encode/pkg-message3
5 files changed, 134 insertions, 0 deletions
diff --git a/multimedia/vtkmpeg2encode/Makefile b/multimedia/vtkmpeg2encode/Makefile
new file mode 100644
index 000000000000..f0c743a00ef9
--- /dev/null
+++ b/multimedia/vtkmpeg2encode/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: vtkmpeg2encode
+# Date created: 2007-12-20
+# Whom: Jason W. Bacon <bacon@smithers.neuro.mcw.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vtkmpeg2encode
+PORTVERSION= 5.0.3
+CATEGORIES= multimedia math
+MASTER_SITES= http://www.vtk.org/files/support/ \
+ http://www.neuro.mcw.edu/Ports/distfiles/VTK5/
+DISTNAME= vtkmpeg2encode
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= VTK MPEG2 encoding library
+
+BUILD_DEPENDS= cmake>=2.2:${PORTSDIR}/devel/cmake
+
+NO_CDROM= the MPEG2 format and all software that uses it is subject to patent restrictions
+NO_PACKAGE= ${NO_CDROM}
+
+CMAKE?= ${LOCALBASE}/bin/cmake
+CMAKE_DEFS+= -DCMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DBUILD_SHARED_LIBS:BOOL=ON
+
+USE_LDCONFIG= yes
+
+MAN3= vtkmpeg2encode.3
+
+SUB_FILES= vtkmpeg2encode.3
+
+MPEGLIB= libvtkMPEG2Encode
+
+PLIST_DIRS= include/vtk-5.0
+PLIST_FILES= lib/${MPEGLIB}.so.${PORTVERSION} \
+ lib/${MPEGLIB}.so.5.0 \
+ lib/${MPEGLIB}.so.5 \
+ lib/${MPEGLIB}.so \
+ include/vtk-5.0/mpeg2encDllConfig.h \
+ include/vtk-5.0/mpeg2enc_global.h \
+ include/vtk-5.0/mpeg2enc.h \
+ include/vtk-5.0/mpeg2enc_config.h \
+ include/vtk-5.0/vlc.h
+
+do-configure:
+ cd ${WRKSRC} && ${CMAKE} . ${CMAKE_DEFS}
+
+post-build:
+ ${MV} ${WRKSRC}/${MPEGLIB}.so ${WRKSRC}/${MPEGLIB}.so.${PORTVERSION}
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/vtk-5.0
+ ${INSTALL_DATA} ${WRKSRC}/${MPEGLIB}.so.${PORTVERSION} ${PREFIX}/lib
+ ${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
+ ${PREFIX}/lib/${MPEGLIB}.so.5.0
+ ${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
+ ${PREFIX}/lib/${MPEGLIB}.so.5
+ ${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
+ ${PREFIX}/lib/${MPEGLIB}.so
+ ${INSTALL_DATA} ${WRKSRC}/mpeg2encDllConfig.h \
+ ${WRKSRC}/mpeg2enc_global.h \
+ ${WRKSRC}/mpeg2enc.h \
+ ${WRKSRC}/mpeg2enc_config.h \
+ ${WRKSRC}/vlc.h \
+ ${PREFIX}/include/vtk-5.0
+ ${INSTALL_MAN} ${WRKDIR}/vtkmpeg2encode.3 ${MANPREFIX}/man/man3
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/multimedia/vtkmpeg2encode/distinfo b/multimedia/vtkmpeg2encode/distinfo
new file mode 100644
index 000000000000..8b203c3457b1
--- /dev/null
+++ b/multimedia/vtkmpeg2encode/distinfo
@@ -0,0 +1,3 @@
+MD5 (vtkmpeg2encode.tar.gz) = 88106f118344dc60e5c2aef5a9aee935
+SHA256 (vtkmpeg2encode.tar.gz) = 4875494be01095377f86b1ad7427cab9a2cd886b2b2b959c96ff742cdda96a2b
+SIZE (vtkmpeg2encode.tar.gz) = 44737
diff --git a/multimedia/vtkmpeg2encode/files/vtkmpeg2encode.3.in b/multimedia/vtkmpeg2encode/files/vtkmpeg2encode.3.in
new file mode 100644
index 000000000000..48d939d574ac
--- /dev/null
+++ b/multimedia/vtkmpeg2encode/files/vtkmpeg2encode.3.in
@@ -0,0 +1,50 @@
+.TH VTKMPEG2ENCODE 3
+.SH NAME \" Section header
+.PP
+
+vtkmpeg2encode - VTK MPEG encoder library
+
+.SH SYNOPSIS
+.PP
+.nf
+.na
+#include <mpeg2enc.h>
+
+-I%%PREFIX%%/include
+
+-L%%PREFIX%%/lib -lvtkMPEG2Encode
+.ad
+.fi
+
+\" Optional sections
+.SH "DESCRIPTION"
+
+This is the VTK MPEG2 encoder library for the Visualization Tool Kit.
+
+vtkmpeg2encode has been removed from VTK due to patent issues with the
+MPEG format.
+
+For those who don't mind dealing with the issues related to patented code,
+vtkmpeg2encode is now available as a separate download. Go to
+http://www.vtk.org and click on the "Download" link and look for links to
+archives of the vtkmpeg2encode source tree. It is buildable with CMake. See
+the comments in vtkMPEG2Writer class documentation or in VTK's
+CMakeLists.txt near the VTK_USE_MPEG2_ENCODER option for more info.
+
+FreeBSD ports users can simply install the vtkmpeg2encode port and read
+the license terms.
+
+Those of you using vtkMPEG2Writer will have to build vtkmpeg2encode
+separately and link it in to VTK to keep using it... assuming the
+responsibility for using patented code properly yourselves. Otherwise, you
+will have to discontinue use of the vtkMPEG2Writer class.
+
+.SH "SEE ALSO"
+vtk(3)
+
+.SH AUTHOR
+.nf
+.na
+Kitware, Inc.
+http://vtk.org
+
diff --git a/multimedia/vtkmpeg2encode/pkg-descr b/multimedia/vtkmpeg2encode/pkg-descr
new file mode 100644
index 000000000000..a6b3b3950410
--- /dev/null
+++ b/multimedia/vtkmpeg2encode/pkg-descr
@@ -0,0 +1,3 @@
+VTK5 MPEG2 Encoder
+
+WWW: http://www.vtk.org/get-software.php#addons
diff --git a/multimedia/vtkmpeg2encode/pkg-message b/multimedia/vtkmpeg2encode/pkg-message
new file mode 100644
index 000000000000..82045d41f3c8
--- /dev/null
+++ b/multimedia/vtkmpeg2encode/pkg-message
@@ -0,0 +1,3 @@
+The MPEG2 format and all software that uses it is subject to patent
+restrictions. Please see http://www.mpegla.com/m2/m2-agreement.cfm
+for more information.