aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/xawtv
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-11-12 01:18:36 +0800
committerOliver Lehmann <oliver@FreeBSD.org>2005-11-12 01:18:36 +0800
commit9e174d0445d4ba09181501631b7f90b370ee8270 (patch)
tree8b63dcfb7cb10ab00d44ca002f6b42b7457d55d9 /multimedia/xawtv
parent154de1f79283c1bedc1ffcedf6575eaf0b220447 (diff)
downloadfreebsd-ports-gnome-9e174d0445d4ba09181501631b7f90b370ee8270.tar.gz
freebsd-ports-gnome-9e174d0445d4ba09181501631b7f90b370ee8270.tar.zst
freebsd-ports-gnome-9e174d0445d4ba09181501631b7f90b370ee8270.zip
fix libquicktime support
PR: ports/88671 Submitted by: Frank W. Josellis
Diffstat (limited to 'multimedia/xawtv')
-rw-r--r--multimedia/xawtv/Makefile11
-rw-r--r--multimedia/xawtv/files/patch-libng-plugins-read-qt.c15
-rw-r--r--multimedia/xawtv/files/patch-libng-plugins-write-qt.c15
3 files changed, 37 insertions, 4 deletions
diff --git a/multimedia/xawtv/Makefile b/multimedia/xawtv/Makefile
index f22415aa0703..c609ab58edf8 100644
--- a/multimedia/xawtv/Makefile
+++ b/multimedia/xawtv/Makefile
@@ -28,7 +28,8 @@ USE_GMAKE= yes
USE_XPM= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
+ DLFLAGS="-L${LOCALBASE}/lib"
MAKE_ENV= verbose=yes
INSTALLS_SHLIB= yes
@@ -112,9 +113,11 @@ pre-everything::
@${ECHO} ""
post-patch:
- @${REINPLACE_CMD} -e "s|/usr/X11R6|${X11BASE}|g" \
- -e "s|/usr/local|${LOCALBASE}|g" \
- -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g; \
+ s|/usr/local|${LOCALBASE}|g; \
+ s|-lpthread|${PTHREAD_LIBS}|g; \
+ s|-lquicktime|-L${LOCALBASE}/lib &|g' \
+ ${WRKSRC}/configure
.for i in ${FILES_LIBJPEG}
@${REINPLACE_CMD} -e "s|-ljpeg|-L${LOCALBASE}/lib -ljpeg|g" ${WRKSRC}/$i
diff --git a/multimedia/xawtv/files/patch-libng-plugins-read-qt.c b/multimedia/xawtv/files/patch-libng-plugins-read-qt.c
new file mode 100644
index 000000000000..607d1717de8e
--- /dev/null
+++ b/multimedia/xawtv/files/patch-libng-plugins-read-qt.c
@@ -0,0 +1,15 @@
+--- libng/plugins/read-qt.c.orig Fri Feb 14 15:13:43 2003
++++ libng/plugins/read-qt.c Tue Nov 8 09:09:45 2005
+@@ -4,9 +4,9 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <pthread.h>
+-#include <quicktime/quicktime.h>
+-#include <quicktime/colormodels.h>
+-#include <quicktime/lqt.h>
++#include <lqt/quicktime.h>
++#include <lqt/colormodels.h>
++#include <lqt/lqt.h>
+
+ #include "grab-ng.h"
+
diff --git a/multimedia/xawtv/files/patch-libng-plugins-write-qt.c b/multimedia/xawtv/files/patch-libng-plugins-write-qt.c
new file mode 100644
index 000000000000..b8773e7d2390
--- /dev/null
+++ b/multimedia/xawtv/files/patch-libng-plugins-write-qt.c
@@ -0,0 +1,15 @@
+--- libng/plugins/write-qt.c.orig Fri Feb 14 15:13:44 2003
++++ libng/plugins/write-qt.c Tue Nov 8 09:18:57 2005
+@@ -4,9 +4,9 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <pthread.h>
+-#include <quicktime/quicktime.h>
+-#include <quicktime/colormodels.h>
+-#include <quicktime/lqt.h>
++#include <lqt/quicktime.h>
++#include <lqt/colormodels.h>
++#include <lqt/lqt.h>
+
+ #include "grab-ng.h"
+