aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-04-21 20:52:56 +0800
committermm <mm@FreeBSD.org>2010-04-21 20:52:56 +0800
commit0248e8afc95e8ac5998744e131a4b88363b050bd (patch)
treea5693d0b1358b3a28d1808af6c36f27780dd01aa /multimedia
parent24a226f306882b19f9400323a0764381b8caee65 (diff)
downloadfreebsd-ports-gnome-0248e8afc95e8ac5998744e131a4b88363b050bd.tar.gz
freebsd-ports-gnome-0248e8afc95e8ac5998744e131a4b88363b050bd.tar.zst
freebsd-ports-gnome-0248e8afc95e8ac5998744e131a4b88363b050bd.zip
- Update to snapshot 20100222 (library version 85)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/x264/Makefile24
-rw-r--r--multimedia/x264/distinfo6
-rw-r--r--multimedia/x264/files/patch-Makefile14
-rw-r--r--multimedia/x264/files/patch-common-common.h8
-rw-r--r--multimedia/x264/pkg-plist2
5 files changed, 28 insertions, 26 deletions
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index 76dfbd48ddc4..7df91d891ae2 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -3,11 +3,9 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $Id: Makefile 30 2006-10-30 22:15:26Z buhnux $
PORTNAME= x264
-PORTVERSION= 0.0.20090119
-PORTREVISION= 2
+PORTVERSION= 0.0.20100222
CATEGORIES= multimedia
MASTER_SITES= http://downloads.videolan.org/pub/videolan/x264/snapshots/ \
http://samples.mplayerhq.hu/yuv4mpeg2/:pgo
@@ -19,9 +17,8 @@ EXTRACT_ONLY= ${PORTNAME}-snapshot-${PORTVERSION:S/0.0.//}-2245${EXTRACT_SUFX}
MAINTAINER= mm@FreeBSD.org
COMMENT?= Library and tool for encoding H.264/AVC video streams
-CONFLICTS= x264-2010*
-
-BUILD_DEPENDS= yasm>=0.6.0:${PORTSDIR}/devel/yasm
+BUILD_DEPENDS= yasm>=0.6.0:${PORTSDIR}/devel/yasm \
+ as:${PORTSDIR}/devel/binutils
USE_BZIP2= yes
EXTRACT_AFTER_ARGS?= | ${TAR} -xf - --exclude .svn
@@ -33,6 +30,7 @@ MAKE_JOBS_SAFE= yes
OPTIONS= DEBUG "Enable Debugging" Off \
PGO "Enable Profile-Guided Optimization" Off \
+ GCC44 "Use gcc 4.4+" Off \
GPAC "Enable MPEG-4 Output" On \
X11_OUTPUT "Enable X11 Output" Off
@@ -40,8 +38,15 @@ CONFIGURE_ARGS+= --extra-cflags="${CPPFLAGS} ${CFLAGS} -fPIC -I${LOCALBASE}/incl
--extra-ldflags="${LDFLAGS} -L${LOCALBASE}/lib -L${LOCALBASE}/lib" \
--enable-shared
+CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
+MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
+
.include <bsd.port.pre.mk>
+.if defined(WITH_GCC44)
+USE_GCC?= 4.4+
+.endif
+
# Around the time GCC stack protection (aka Propolice) for userland
# was enabled on src/share/mk/bsd.sys.mk
# SVN rev 180012 on 2008-06-25 21:33:28Z by ru
@@ -75,7 +80,7 @@ RESTRICTED_FILES= ${Y4M_VIDEO_DISTFILE}
.endif
.if !defined(WITHOUT_GPAC)
-BUILD_DEPENDS+= gpac-libgpac>=0.4.2.r2,1:${PORTSDIR}/multimedia/gpac-libgpac
+BUILD_DEPENDS+= gpac-libgpac>=0.4.5,1:${PORTSDIR}/multimedia/gpac-libgpac
LIB_DEPENDS+= gpac.1:${PORTSDIR}/multimedia/gpac-libgpac
CONFIGURE_ARGS+= --enable-mp4-output
.else
@@ -102,6 +107,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|; \
s|$${libdir}/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/Makefile
+.if !defined(WITH_GCC44)
+ @${REINPLACE_CMD} -e 's|$$(CC) -shared -o|COMPILER_PATH= $$(CC) -shared -o|g' \
+ -e 's|$$(CC) -o|COMPILER_PATH= $$(CC) -o|g' \
+ ${WRKSRC}/Makefile
+.endif
.if ${SLAVE_PORT:L}=="no"
.if 0 # BROKEN
diff --git a/multimedia/x264/distinfo b/multimedia/x264/distinfo
index 549f1dab1fc1..5f2428bd15e8 100644
--- a/multimedia/x264/distinfo
+++ b/multimedia/x264/distinfo
@@ -1,6 +1,6 @@
-MD5 (x264/x264-snapshot-20090119-2245.tar.bz2) = 31c6b9aea1aef45003f69880a250609a
-SHA256 (x264/x264-snapshot-20090119-2245.tar.bz2) = db5932675a52dba439b2611c2d4fc96f5a71d1ed2a3b35bac1659aa4928e5ef2
-SIZE (x264/x264-snapshot-20090119-2245.tar.bz2) = 2381449
+MD5 (x264/x264-snapshot-20100222-2245.tar.bz2) = a68827d2e47920ee3ae655f8b8c51013
+SHA256 (x264/x264-snapshot-20100222-2245.tar.bz2) = 6f197d825315f077fabaf6340c324462cdceaf0417500dadea3511b1ad26ac2f
+SIZE (x264/x264-snapshot-20100222-2245.tar.bz2) = 400392
MD5 (x264/example.y4m.bz2) = e0948016cd4a52e75d6a74d998bd6ae6
SHA256 (x264/example.y4m.bz2) = a5bec9d37362bd9d7773fbd0644643f9ec096d654d20823004e88d5df32bbff7
SIZE (x264/example.y4m.bz2) = 4910029
diff --git a/multimedia/x264/files/patch-Makefile b/multimedia/x264/files/patch-Makefile
index 9be78fa7c198..5c743b2b520e 100644
--- a/multimedia/x264/files/patch-Makefile
+++ b/multimedia/x264/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2008-12-18 13:45:07.000000000 -0800
-+++ Makefile 2010-02-27 15:21:32.000000000 -0800
-@@ -26,12 +26,12 @@
+--- Makefile.orig 2010-02-22 22:45:05.000000000 +0100
++++ Makefile 2010-04-18 10:43:06.325179277 +0200
+@@ -53,12 +53,12 @@
cpu-a.asm dct-32.asm
X86SRC = $(X86SRC0:%=common/x86/%)
@@ -15,12 +15,12 @@
ARCH_X86 = yes
ASMSRC = $(X86SRC:-32.asm=-64.asm)
ASFLAGS += -DARCH_X86_64
-@@ -47,7 +47,7 @@
+@@ -74,7 +74,7 @@
endif
# AltiVec optims
-ifeq ($(ARCH),PPC)
+ifeq ($(ARCH),powerpc)
- ALTIVECSRC += common/ppc/mc.c common/ppc/pixel.c common/ppc/dct.c \
- common/ppc/quant.c common/ppc/deblock.c \
- common/ppc/predict.c
+ SRCS += common/ppc/mc.c common/ppc/pixel.c common/ppc/dct.c \
+ common/ppc/quant.c common/ppc/deblock.c \
+ common/ppc/predict.c
diff --git a/multimedia/x264/files/patch-common-common.h b/multimedia/x264/files/patch-common-common.h
deleted file mode 100644
index 14ee0523b5be..000000000000
--- a/multimedia/x264/files/patch-common-common.h
+++ /dev/null
@@ -1,8 +0,0 @@
---- common/common.h.orig 2010-02-03 17:25:48.378388768 +0100
-+++ common/common.h 2010-02-03 17:26:24.401327942 +0100
-@@ -634,3 +634,5 @@
-
- #endif
-
-+#define M_LOG2_E 0.693147180559945309417
-+#define log2f(x) (logf (x) / (float) M_LOG2_E)
diff --git a/multimedia/x264/pkg-plist b/multimedia/x264/pkg-plist
index 812fa439d06c..0a24c478cdf9 100644
--- a/multimedia/x264/pkg-plist
+++ b/multimedia/x264/pkg-plist
@@ -2,5 +2,5 @@ bin/x264
include/x264.h
lib/libx264.a
lib/libx264.so
-lib/libx264.so.65
+lib/libx264.so.85
libdata/pkgconfig/x264.pc