aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2006-02-19 16:55:51 +0800
committerlioux <lioux@FreeBSD.org>2006-02-19 16:55:51 +0800
commit06cd6e61fccc1ac6ae352b1ebebb3322fee68037 (patch)
treec984359edeb117356277bb85ec69091c6f3a92a9 /multimedia
parent0f2f8856f3a5575f4d4ce22e4599ef94b7a38d80 (diff)
downloadfreebsd-ports-gnome-06cd6e61fccc1ac6ae352b1ebebb3322fee68037.tar.gz
freebsd-ports-gnome-06cd6e61fccc1ac6ae352b1ebebb3322fee68037.tar.zst
freebsd-ports-gnome-06cd6e61fccc1ac6ae352b1ebebb3322fee68037.zip
o Fix misbehavior of makexml that adds extra n's at the XML code,
rendering it useless. o Bump PORTREVISION PR: 92084 Submitted by: edwin
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/tovid/Makefile2
-rw-r--r--multimedia/tovid/files/patch-src__makexml.sh65
2 files changed, 66 insertions, 1 deletions
diff --git a/multimedia/tovid/Makefile b/multimedia/tovid/Makefile
index f0b28f81ea0f..79a86a0c006b 100644
--- a/multimedia/tovid/Makefile
+++ b/multimedia/tovid/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tovid
PORTVERSION= 0.24
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia python
MASTER_SITES= http://download.berlios.de/tovid/
diff --git a/multimedia/tovid/files/patch-src__makexml.sh b/multimedia/tovid/files/patch-src__makexml.sh
new file mode 100644
index 000000000000..bb968b4dd94f
--- /dev/null
+++ b/multimedia/tovid/files/patch-src__makexml.sh
@@ -0,0 +1,65 @@
+--- src/makexml.sh.orig Sun Feb 19 05:52:41 2006
++++ src/makexml.sh Sun Feb 19 05:52:41 2006
+@@ -183,7 +183,7 @@
+ # Generate XML for the button linking to this titleset menu from the top menu
+ TOP_MENU_BUTTONS=`cat << EOF
+ $TOP_MENU_BUTTONS\
+- <button>jump titleset $CUR_TS menu;<\/button>\n
++ <button>jump titleset $CUR_TS menu;<\/button>
+ EOF`
+
+ # Generate XML for the menu header, with a placeholder for
+@@ -206,7 +206,7 @@
+ # Generate XML for the button linking to this menu from the top menu
+ TOP_MENU_BUTTONS=`cat << EOF
+ $TOP_MENU_BUTTONS\
+- <select ref="select-menu-$CUR_TS"\/>\n
++ <select ref="select-menu-$CUR_TS"\/>
+ EOF`
+
+ # Generate XML for the segment item
+@@ -271,7 +271,7 @@
+ if [ $CUR_VIDEO -lt 2 ]; then
+ MENU_BUTTONS=`cat << EOF
+ $MENU_BUTTONS\
+- <button>jump title $CUR_TITLE;<\/button>\n
++ <button>jump title $CUR_TITLE;<\/button>
+ EOF`
+ fi
+ else
+@@ -279,7 +279,7 @@
+ if [ $CUR_VIDEO -le 1 ]; then
+ TOP_MENU_BUTTONS=`cat << EOF
+ $TOP_MENU_BUTTONS\
+- <button>jump titleset $CUR_TS menu;<\/button>\n
++ <button>jump titleset $CUR_TS menu;<\/button>
+ EOF`
+ fi
+ fi
+@@ -377,7 +377,7 @@
+ if $FIRST_TITLE; then
+ MENU_BUTTONS=`cat << EOF
+ $MENU_BUTTONS
+- <select ref="play-title-$CUR_TITLE"\/>\n
++ <select ref="play-title-$CUR_TITLE"\/>
+ EOF`
+ fi
+
+@@ -413,7 +413,7 @@
+ # jump to this playlist (title)
+ MENU_BUTTONS=`cat << EOF
+ $MENU_BUTTONS\
+- <select ref="play-title-$CUR_TITLE"\/>\n
++ <select ref="play-title-$CUR_TITLE"\/>
+ EOF`
+
+ # Generate XML for the sequence item
+@@ -457,7 +457,7 @@
+ if $HAVE_TOP_MENU; then
+ MENU_BUTTONS=`cat << EOF
+ $MENU_BUTTONS\
+- <button>jump vmgm menu;<\/button>\n
++ <button>jump vmgm menu;<\/button>
+ EOF`
+ fi
+