aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
committerbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
commit11557d3b1ca381824ecc50f020623ed56d4ce36a (patch)
tree81627af7b0f0c701d807cb8a4046a4740517b9f9 /multimedia
parent1ed12c409b16770d2cb109c7a67bf65ef1a3f27b (diff)
downloadfreebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.gz
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.zst
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.zip
Add a new USES=waf to handle the waf building system, allowing to factorise code
Plug waf into MAKE_CMD and CONFIGURE_CMD so the regular defined targets can be reused Always define _MAKE_JOBS so that when bsd.port.mk will stop overwritting _MAKE_JOBS when parallel jobs are disabled we can enforce -j1 (which is needed to really disable parallelisation with waf WAF_CMD has been created to allow one to override the location of the waf script relatively to WRKSRC CONFIGURE_TARGET is by default defined to "configure" ALL_TARGET is by default defined to "build" INSTALL_TARGET is by default defined to "install" USES=waf is by default stagedir safe
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpv/Makefile16
1 files changed, 1 insertions, 15 deletions
diff --git a/multimedia/mpv/Makefile b/multimedia/mpv/Makefile
index b4d810c7e023..5548d0de9eed 100644
--- a/multimedia/mpv/Makefile
+++ b/multimedia/mpv/Makefile
@@ -28,7 +28,7 @@ GH_COMMIT= ff4c1cc
WAF_VERSION= 1.8.7
-USES= compiler:c11 desktop-file-utils iconv pkgconfig python:build
+USES= compiler:c11 desktop-file-utils iconv pkgconfig python:build waf
USE_XORG= x11 xv xxf86vm
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -126,8 +126,6 @@ JACK_CONFIGURE_ENABLE= jack
PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE= pulse
-.include <bsd.port.options.mk>
-
post-extract:
${CP} ${DISTDIR}/waf-${WAF_VERSION} ${WRKSRC}/waf
@${CHMOD} +x ${WRKSRC}/waf
@@ -138,18 +136,6 @@ post-patch:
@${FIND} ${WRKSRC}/DOCS/man -name '*.rst' | ${XARGS} ${REINPLACE_CMD} \
-e 's|/usr/local|${PREFIX}|g'
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
- waf configure ${_MAKE_JOBS} ${CONFIGURE_ARGS}
-
-do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
- waf build ${_MAKE_JOBS}
-
-do-install:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
- waf install --destdir=${STAGEDIR}
-
post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mpv
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmpv.so