aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
commit12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5 (patch)
treeee1202c5a5464562474562e70212261185323b7d /multimedia
parent82b2604cbc93a294ed39ce8da691d406c1342992 (diff)
downloadfreebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.gz
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.zst
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.zip
Fix build on gcc-based archs by updating USES.
Tested on powerpc64 and amd64 (for no regression). While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libvdpau-va-gl/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/multimedia/libvdpau-va-gl/Makefile b/multimedia/libvdpau-va-gl/Makefile
index 0c8181a61276..d2a06b9299a2 100644
--- a/multimedia/libvdpau-va-gl/Makefile
+++ b/multimedia/libvdpau-va-gl/Makefile
@@ -2,8 +2,8 @@
PORTNAME= libvdpau-va-gl
PORTVERSION= 0.4.2
-PORTREVISION= 2
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -15,15 +15,14 @@ COMMENT= VDPAU driver with OpenGL/VAAPI backend
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libva-x11.so:multimedia/libva
-
BROKEN_armv6= fails to configure: CMake Error: Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- broken
-BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
+LIB_DEPENDS= libva-x11.so:multimedia/libva
USE_GITHUB= yes
GH_ACCOUNT= i-rinat
-USES= cmake pkgconfig
+USES= cmake compiler:c++11-lang pkgconfig
USE_XORG= x11
USE_GL= gl
LDFLAGS+= -Wl,--as-needed # Xext, ICE, SM