aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-02-24 10:56:30 +0800
committerlioux <lioux@FreeBSD.org>2004-02-24 10:56:30 +0800
commit149329806aab79cb24f72c98412d0d75354280fd (patch)
tree5c6df6ffa0afc8fecd92d8553413cd5535b29d38 /multimedia
parent7bc9d2a3f28c49bf1aa135ea885f999bcc94ac36 (diff)
downloadfreebsd-ports-gnome-149329806aab79cb24f72c98412d0d75354280fd.tar.gz
freebsd-ports-gnome-149329806aab79cb24f72c98412d0d75354280fd.tar.zst
freebsd-ports-gnome-149329806aab79cb24f72c98412d0d75354280fd.zip
o FreeBSD 5.x series had gcc 3.2.x per default up until OSVERSION
501103. However, users from FreeBSD series previous to 5.x are required to build gcc32 port. o Therefore, do not force 5.x users to build gcc33 port if their available gcc32 toolchain will do. In so many words, .if ${OSVERSION} < 501103 USE_GCC=3.2 .else USE_GCC=3.3 .endif Prompted by: markus Reviewed by: markus, will
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libmatroska/Makefile7
-rw-r--r--multimedia/mkvtoolnix/Makefile6
2 files changed, 12 insertions, 1 deletions
diff --git a/multimedia/libmatroska/Makefile b/multimedia/libmatroska/Makefile
index d051bbb8b929..ae4ce1c95086 100644
--- a/multimedia/libmatroska/Makefile
+++ b/multimedia/libmatroska/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libmatroska
PORTVERSION= 0.6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio
MASTER_SITES= http://dl.matroska.org/downloads/libmatroska/
@@ -49,6 +49,11 @@ do-configure:
.if ${OSVERSION} < 500000
# this is gcc 2.x
CFLAGS+= -DNO_WSTRING
+.endif
+
+# gcc 3.2 was available on 5.x before this OSVERSION
+# do not build gcc 3.3 unless necessary
+.if ${OSVERSION} < 501103
# use gcc 3.2
USE_GCC=3.2
.else
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index efbf773995be..13e3be6c78ee 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mkvtoolnix
PORTVERSION= 0.8.5
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://www.bunkus.org/videotools/mkvtoolnix/sources/
@@ -39,6 +40,11 @@ post-patch:
.if ${OSVERSION} < 500000
# this is gcc 2.x
CFLAGS+= -DNO_WSTRING
+.endif
+
+# gcc 3.2 was available on 5.x before this OSVERSION
+# do not build gcc 3.3 unless necessary
+.if ${OSVERSION} < 501103
# use gcc 3.2
USE_GCC=3.2
.else