aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2010-07-14 09:22:28 +0800
committerwxs <wxs@FreeBSD.org>2010-07-14 09:22:28 +0800
commit1ef5d20b8d2956ab5711b51a3f29828abd10ae53 (patch)
treeb89fb4ee7ee5cc12fbfe65121d3e583a0219d0a7 /multimedia
parentce9bc5e9adaabe129f70c64b9372f230557eda3b (diff)
downloadfreebsd-ports-gnome-1ef5d20b8d2956ab5711b51a3f29828abd10ae53.tar.gz
freebsd-ports-gnome-1ef5d20b8d2956ab5711b51a3f29828abd10ae53.tar.zst
freebsd-ports-gnome-1ef5d20b8d2956ab5711b51a3f29828abd10ae53.zip
Properly fix build on 7.x. The proper OSVERSION check should be 703100.
Also fix a bizarre scenario where ${FAKEDIR}/share/kde4 was not being created. The root cause of this is still not determined but this should fix it for now. Submitted by: Joseph Atkinson <jsa@wickedmachine.net>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index fc3253f3a9bb..3ea6796c775d 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -167,7 +167,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-modules__misc__inhibit__xdg.c \
${FILESDIR}/extra-patch-modules__misc__inhibit__xscreensaver.c
.endif
-.if (${OSVERSION} < 702102)
+.if (${OSVERSION} < 703100)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-modules__access__file.c \
${FILESDIR}/extra-patch-modules__access__fs.c
.endif
@@ -667,11 +667,12 @@ pre-install:
${SED} -e 's|^|@dirrmtry libdata/|' >> ${PLIST} ; \
fi
.for dir in icons kde4 vlc
+ if [ -d ${FAKEDIR}/share/${dir} ]; then \
cd ${FAKEDIR}/share/${dir} && ${FIND} -s * -type f -o -type l | \
${SED} -e 's|^|share/${dir}/|' >> ${PLIST} \
&& ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrmtry share/${dir}/|' >> ${PLIST}
- ${ECHO_CMD} "@dirrmtry share/${dir}" >> ${PLIST}
+ ${SED} -e 's|^|@dirrmtry share/${dir}/|' >> ${PLIST} \
+ && ${ECHO_CMD} "@dirrmtry share/${dir}" >> ${PLIST}
.endfor
.if !defined(NOPORTDOCS)
cd ${FAKEDIR}/share/doc && ${FIND} -s * -type f -o -type l | \