aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-10-21 00:35:07 +0800
committertcberner <tcberner@FreeBSD.org>2018-10-21 00:35:07 +0800
commit26ee30759c6021e9b92231e566ef3b8c8999beb1 (patch)
tree886c30f14cc1769977e30620802bc3e97b4b8a78 /multimedia
parent138e55d4ae33cd06ced518b640fe4455e5450db9 (diff)
downloadfreebsd-ports-gnome-26ee30759c6021e9b92231e566ef3b8c8999beb1.tar.gz
freebsd-ports-gnome-26ee30759c6021e9b92231e566ef3b8c8999beb1.tar.zst
freebsd-ports-gnome-26ee30759c6021e9b92231e566ef3b8c8999beb1.zip
multimedia/gstreamer1-qt: fix build of qt5 flavor with GCC-based architectures
PR: 232262 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer1-qt/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/gstreamer1-qt/Makefile b/multimedia/gstreamer1-qt/Makefile
index a3eaa60d210c..61e789c4b7cb 100644
--- a/multimedia/gstreamer1-qt/Makefile
+++ b/multimedia/gstreamer1-qt/Makefile
@@ -19,7 +19,7 @@ FLAVOR?= ${FLAVORS:[1]}
CONFLICTS_INSTALL= gstreamer${PKGNAMESUFFIX}-*
-USES= bison cmake:outsource pathfix pkgconfig tar:xz
+USES= bison cmake:outsource gl gnome pathfix pkgconfig tar:xz
USE_GSTREAMER1= yes
USE_GL= gl
@@ -35,7 +35,7 @@ USE_QT= corelib gui opengl declarative script \
qmake_build moc_build rcc_build uic_build qtestlib_build
PLIST_SUB= QT4_ONLY="" QT5_ONLY="@comment "
. else
-USES+= qt:5
+USES+= compiler:c++11-lang qt:5
USE_QT= buildtools_build qmake_build core gui network opengl \
qml quick testlib widgets
QTVER_SUFFIX= 5