aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-03 04:23:55 +0800
committerKoop Mast <kwm@FreeBSD.org>2015-08-03 04:23:55 +0800
commit2f0486b64721a1072cdd1b8d2840d6539b2247d2 (patch)
tree36ed89e03b0f2ac4525ba4f4e39af16da597b209 /multimedia
parent05aa1eb8b1e5d76cddd216c787c98b5cfe7db1e9 (diff)
downloadfreebsd-ports-gnome-2f0486b64721a1072cdd1b8d2840d6539b2247d2.tar.gz
freebsd-ports-gnome-2f0486b64721a1072cdd1b8d2840d6539b2247d2.tar.zst
freebsd-ports-gnome-2f0486b64721a1072cdd1b8d2840d6539b2247d2.zip
Part 1 of adding USE_GNOME=intltool to ports that require it.
The reason for this is that in the GNOME 3.16 update, USE_GNOME gtk20 and gtk30 don't pull intltool in anymore. PR: 201980 Exp-run by: antoine@
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/banshee/Makefile2
-rw-r--r--multimedia/freetuxtv/Makefile2
-rw-r--r--multimedia/gaupol/Makefile2
-rw-r--r--multimedia/gmtk/Makefile2
-rw-r--r--multimedia/gnome-subtitles/Makefile2
-rw-r--r--multimedia/handbrake/Makefile2
-rw-r--r--multimedia/lives/Makefile2
-rw-r--r--multimedia/pitivi/Makefile2
-rw-r--r--multimedia/quodlibet/Makefile2
-rw-r--r--multimedia/subtitleeditor/Makefile2
10 files changed, 10 insertions, 10 deletions
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 8c8086777bd6..2933ecdf494e 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -36,7 +36,7 @@ USES= desktop-file-utils gmake libtool mono pathfix perl5 \
pkgconfig shared-mime-info tar:xz
USE_PERL5= build
GNU_CONFIGURE= yes
-USE_GNOME= gnomedocutils gnomesharp20 gtksharp20
+USE_GNOME= gnomedocutils gnomesharp20 gtksharp20 intltool
USE_GSTREAMER= cdparanoia
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME:C/-.*//}
USE_XORG= xrandr xxf86vm
diff --git a/multimedia/freetuxtv/Makefile b/multimedia/freetuxtv/Makefile
index 897a1d870ed4..4714041f1117 100644
--- a/multimedia/freetuxtv/Makefile
+++ b/multimedia/freetuxtv/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libvlc.so:${PORTSDIR}/multimedia/vlc \
libnotify.so:${PORTSDIR}/devel/libnotify
USES= gmake iconv libtool pkgconfig
-USE_GNOME= gtk30
+USE_GNOME= gtk30 intltool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk=3.0
CFLAGS+= -Wno-return-type -w
diff --git a/multimedia/gaupol/Makefile b/multimedia/gaupol/Makefile
index 4855634fb2a5..e8a9f6071dd8 100644
--- a/multimedia/gaupol/Makefile
+++ b/multimedia/gaupol/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes \
py*-chardet>=0:${PORTSDIR}/textproc/py-chardet \
py*-enchant>=1.5.1:${PORTSDIR}/textproc/py-enchant
-USE_GNOME= pygtk2
+USE_GNOME= pygtk2 intltool
USE_PYTHON= distutils
USES= desktop-file-utils python
INSTALLS_ICONS= yes
diff --git a/multimedia/gmtk/Makefile b/multimedia/gmtk/Makefile
index ed4c58be5d63..43d9781fa06b 100644
--- a/multimedia/gmtk/Makefile
+++ b/multimedia/gmtk/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= p5-XML-Parser>0:${PORTSDIR}/textproc/p5-XML-Parser
USES= gettext gmake libtool pathfix perl5 pkgconfig
USE_XORG= x11
-USE_GNOME= glib20
+USE_GNOME= glib20 intltool
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules \
diff --git a/multimedia/gnome-subtitles/Makefile b/multimedia/gnome-subtitles/Makefile
index 6401f3f8c8b1..32534ad4a9e1 100644
--- a/multimedia/gnome-subtitles/Makefile
+++ b/multimedia/gnome-subtitles/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
USES= cpe gmake mono pkgconfig libtool desktop-file-utils
CPE_VENDOR= pedro_castro
-USE_GNOME= gnomeprefix gtksharp20 gnomesharp20 gnomedocutils
+USE_GNOME= gnomeprefix gtksharp20 gnomesharp20 gnomedocutils intltool
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 128dfba17da4..1f3103645a39 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -90,7 +90,7 @@ LIBS+= -L${LOCALBASE}/lib
LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libnotify.so:${PORTSDIR}/devel/libnotify
USES+= gettext
-USE_GNOME+= gtk30
+USE_GNOME+= gtk30 intltool
PLIST_FILES+= bin/HandBrake
DESKTOP_ENTRIES="HandBrake" \
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index b7ae04ac9b56..aa50ca94e811 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -47,7 +47,7 @@ SHEBANG_FILES= build-lives-rfx-plugin build-lives-rfx-plugin-multi \
smogrify tools/autolives.pl
GNU_CONFIGURE= yes
USE_CSTD= gnu89
-USE_GNOME= gtk30
+USE_GNOME= gtk30 intltool
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-ldvgrab
diff --git a/multimedia/pitivi/Makefile b/multimedia/pitivi/Makefile
index 98528787477b..082a98d187b0 100644
--- a/multimedia/pitivi/Makefile
+++ b/multimedia/pitivi/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= py*-zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_SITELIBDIR}/goocanvasmodule.so:${PORTSDIR}/graphics/py-goocanvas
USES= gettext gmake pkgconfig python tar:bzip2
-USE_GNOME= pygtk2
+USE_GNOME= intltool pygtk2
USE_GSTREAMER= gnonlin python good
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/multimedia/quodlibet/Makefile b/multimedia/quodlibet/Makefile
index 039d9e4fcdd0..55422eb816a0 100644
--- a/multimedia/quodlibet/Makefile
+++ b/multimedia/quodlibet/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>0:${PORTSDIR}/audio/py-mutagen
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>0:${PORTSDIR}/audio/py-mutagen
USE_PYTHON= distutils autoplist
-USE_GNOME= pygtk2
+USE_GNOME= intltool pygtk2
USES= display gettext python
PYDISTUTILS_INSTALLNOSINGLE= yes
diff --git a/multimedia/subtitleeditor/Makefile b/multimedia/subtitleeditor/Makefile
index d6ed75838797..d743cf23ad09 100644
--- a/multimedia/subtitleeditor/Makefile
+++ b/multimedia/subtitleeditor/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libglademm-2.4.so:${PORTSDIR}/devel/libglademm24 \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= desktop-file-utils gettext gmake libtool pkgconfig
-USE_GNOME= gtkmm24
+USE_GNOME= gtkmm24 intltool
USE_GSTREAMER= good mm
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip