aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2011-06-27 21:16:04 +0800
committerbsam <bsam@FreeBSD.org>2011-06-27 21:16:04 +0800
commit33c859c4a5c84089a56daaf1e79bf4887ea46f6a (patch)
tree0597737483bbdfbff818c7d918de2c00ac1460fc /multimedia
parent668fa7bbfaaf4348cdbe05e768e133c5d250dcc7 (diff)
downloadfreebsd-ports-gnome-33c859c4a5c84089a56daaf1e79bf4887ea46f6a.tar.gz
freebsd-ports-gnome-33c859c4a5c84089a56daaf1e79bf4887ea46f6a.tar.zst
freebsd-ports-gnome-33c859c4a5c84089a56daaf1e79bf4887ea46f6a.zip
Fix an error at I386:
zmwatch[2429].ERR [Shared data size conflict in shared_data for monitor Monitor-1, expected 328, got 316] The patch for i386 ($arch should be 32 here but perl uses 64 bit integer): ----- -our $arch = int(3.2*length(~0)); +our $arch = 32; ----- I'm not sure how to properly fix this. I'm all ears. Suggested by: Yury Bushmelev <jay4mail@gmail.com> (via e-mail)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/zoneminder/Makefile11
-rw-r--r--multimedia/zoneminder/files/extra-patch-scripts_ZoneMinder_lib_ZoneMinder_Memory.pm.in11
2 files changed, 20 insertions, 2 deletions
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index d0e49e7fa949..b2cca4044c94 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zoneminder
PORTVERSION= 1.24.4
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= multimedia
MASTER_SITES= http://www2.zoneminder.com/downloads/ \
http://www.zoneminder.com/downloads/
@@ -121,4 +121,11 @@ post-install:
${INSTALL_MAN} ${FILESDIR}/README.FreeBSD ${DOCSDIR}
.endif
${CAT} ${FILESDIR}/README.FreeBSD
-.include <bsd.port.mk>
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH}=="i386"
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-scripts_ZoneMinder_lib_ZoneMinder_Memory.pm.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/zoneminder/files/extra-patch-scripts_ZoneMinder_lib_ZoneMinder_Memory.pm.in b/multimedia/zoneminder/files/extra-patch-scripts_ZoneMinder_lib_ZoneMinder_Memory.pm.in
new file mode 100644
index 000000000000..be7698c9d7ea
--- /dev/null
+++ b/multimedia/zoneminder/files/extra-patch-scripts_ZoneMinder_lib_ZoneMinder_Memory.pm.in
@@ -0,0 +1,11 @@
+--- scripts/ZoneMinder/lib/ZoneMinder/Memory.pm.in.orig 2011-05-20 19:43:27.000000000 +0400
++++ scripts/ZoneMinder/lib/ZoneMinder/Memory.pm.in 2011-06-27 16:28:59.894374784 +0400
+@@ -127,7 +127,7 @@ else
+ }
+
+ # Native architecture
+-our $arch = int(3.2*length(~0));
++our $arch = 32;
+ our $native = $arch/8;
+ our $mem_seq = 0;
+