aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-05 20:17:08 +0800
committerwill <will@FreeBSD.org>2001-03-05 20:17:08 +0800
commit37b062ed62665ace31e4373b458cc75681213764 (patch)
treeb8f38166d53aef4457fc65f9d36d8ee0e550e5ce /multimedia
parenta60ff5681296acc284a5fdc038a18ac26c9daef4 (diff)
downloadfreebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.tar.gz
freebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.tar.zst
freebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.zip
Attempt to fix conflicts with a local getopt.h (specifically, the fix is
for libgnugetopt's getopt.h). Not tested, but should work.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/kdemultimedia3/Makefile2
-rw-r--r--multimedia/kdemultimedia4/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/kdemultimedia3/Makefile b/multimedia/kdemultimedia3/Makefile
index 50c3174949fc..ca5f0709a0b4 100644
--- a/multimedia/kdemultimedia3/Makefile
+++ b/multimedia/kdemultimedia3/Makefile
@@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc" \
USER_LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/multimedia/kdemultimedia4/Makefile b/multimedia/kdemultimedia4/Makefile
index 50c3174949fc..ca5f0709a0b4 100644
--- a/multimedia/kdemultimedia4/Makefile
+++ b/multimedia/kdemultimedia4/Makefile
@@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc" \
USER_LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes