aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-08 19:32:11 +0800
committerbapt <bapt@FreeBSD.org>2013-03-08 19:32:11 +0800
commit385eac9654e9de3b90ce25e1efffa8c08a547655 (patch)
tree9c130b083139cc77280c7e96cc9cea75a84d2d4c /multimedia
parentf2d169546a0f3c0e7fb3d21a855ac4b44aae5036 (diff)
downloadfreebsd-ports-gnome-385eac9654e9de3b90ce25e1efffa8c08a547655.tar.gz
freebsd-ports-gnome-385eac9654e9de3b90ce25e1efffa8c08a547655.tar.zst
freebsd-ports-gnome-385eac9654e9de3b90ce25e1efffa8c08a547655.zip
Convert USE_BISON to USES= bison
It brings bison as a build dependency in case it is set the following way: USES= bison or USES= bison:build it brings bison as a run dependency in case it is set the following way: USES= bison:run it brings bison both as a run and build dependency in case it the set the following way: USES= bison:both While here trim some headers Convert some USE_GNOME= gnomehack to USES= pathfix
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avinfo/Makefile9
-rw-r--r--multimedia/gstreamer-qt4/Makefile2
-rw-r--r--multimedia/gstreamer/Makefile5
-rw-r--r--multimedia/libaacs/Makefile8
4 files changed, 7 insertions, 17 deletions
diff --git a/multimedia/avinfo/Makefile b/multimedia/avinfo/Makefile
index ac5a06ce61dc..00d0b401339f 100644
--- a/multimedia/avinfo/Makefile
+++ b/multimedia/avinfo/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection Makefile for: avinfo
-# Date created: Feb 7, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= avinfo
PORTVERSION= 1.0.a15
@@ -17,7 +12,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A utility for displaying AVI header information
USE_GMAKE= yes
-USE_BISON= build
+USES= bison
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/multimedia/gstreamer-qt4/Makefile b/multimedia/gstreamer-qt4/Makefile
index d0fc923886af..8bb8d4c5e1be 100644
--- a/multimedia/gstreamer-qt4/Makefile
+++ b/multimedia/gstreamer-qt4/Makefile
@@ -16,7 +16,7 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_CMAKE= yes
USE_GMAKE= yes
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index d7113454e069..fd5f915a05a6 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -17,11 +17,10 @@ RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/GLib-2.0.gir:${PORTSDIR}/devel/gobject-i
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
CFLAGS:= ${CFLAGS} -O2 -Wno-format
-USE_BISON= build
+USES= bison pathfix
USE_BZIP2= yes
USE_GMAKE= yes
-WANT_GNOME= yes
-USE_GNOME= gnomehack glib20 libxml2 ltverhack ltasneededhack
+USE_GNOME= glib20 libxml2 ltverhack ltasneededhack
USE_PKGCONFIG= build
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool
diff --git a/multimedia/libaacs/Makefile b/multimedia/libaacs/Makefile
index 06d454333f82..380a2740cb1e 100644
--- a/multimedia/libaacs/Makefile
+++ b/multimedia/libaacs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libaacs
-# Date created: 19 February 2011
-# Whom: kamikaze@bsdforen.de
-#
+# Created by: kamikaze@bsdforen.de
# $FreeBSD$
-#
PORTNAME= libaacs
PORTVERSION= 0.3.0
@@ -23,7 +19,7 @@ USE_GETTEXT= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf aclocal automake libtool
-USE_BISON= build
+USES= bison
MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes