aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
committeranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
commit3c76fd7fad82c9f137407348028fde08754f2866 (patch)
tree9818557f7ca7be09aba8db3b18a8262f50280603 /multimedia
parenta861bc861bc7251a2f2399f845d673f742a19ee1 (diff)
downloadfreebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.gz
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.zst
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.zip
- Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,
and make XFREE86_VERSION map to it. XFREE86_VERSION is now deprecated. - Make xorg the default X_WINDOW_SYSTEM on -current. - Add several new X_*_PORT variables which point to various pieces of X11 based on the setting of X_WINDOW_SYSTEM, and make ports use them. - Add information to CHANGES about how to handle the transition. PR: ports/68763 Approved by: portmgr (marcus) Approved by: re (scottl)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libdv/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/multimedia/libdv/Makefile b/multimedia/libdv/Makefile
index 620955b1f573..5f6b2791a76c 100644
--- a/multimedia/libdv/Makefile
+++ b/multimedia/libdv/Makefile
@@ -34,6 +34,10 @@ PORTDOCS= AUTHORS COPYING COPYRIGHT ChangeLog NEWS README \
.include <bsd.port.pre.mk>
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+IGNORE= "Requires Xv Extension"
+.endif
+
# XXX - work around compiler bug
# Optimizations -O{1,s,2,3} work
# However, lack of -O{1,s,2,3} or -O0 BREAK the build
@@ -46,15 +50,6 @@ CONFIGURE_ARGS+= --enable-sdl
.endif
pre-everything::
-.if ${XFREE86_VERSION} < 4
- @${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> ATTENTION <==='
- @${ECHO_MSG} '===> YOU NEED XFREE86 Version 4.0 <==='
- @${ECHO_MSG} '===> or above to run this <==='
- @${ECHO_MSG} '===> SINCE IT REQUIRES XV <==='
- @${ECHO_MSG} '===>'
- @${FALSE}
-.endif
.ifndef(WITHOUT_SDL)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITHOUT_SDL to disable SDL support'