aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-11-29 05:57:01 +0800
committerkwm <kwm@FreeBSD.org>2013-11-29 05:57:01 +0800
commit432bca168f7827a08a38b9e68043d9d9e9e96e91 (patch)
tree07b588f8d7ae8b1ab4c626520a43294288d2ec73 /multimedia
parent1917244b0c77d9adf66a0cfab3caeec2aec18f40 (diff)
downloadfreebsd-ports-gnome-432bca168f7827a08a38b9e68043d9d9e9e96e91.tar.gz
freebsd-ports-gnome-432bca168f7827a08a38b9e68043d9d9e9e96e91.tar.zst
freebsd-ports-gnome-432bca168f7827a08a38b9e68043d9d9e9e96e91.zip
Add gstreamer vaapi, plugin and support libraries to enable hardware
accelerated video decoding through the VA-API library.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/gstreamer1-vaapi/Makefile38
-rw-r--r--multimedia/gstreamer1-vaapi/distinfo2
-rw-r--r--multimedia/gstreamer1-vaapi/pkg-descr8
-rw-r--r--multimedia/gstreamer1-vaapi/pkg-plist52
5 files changed, 101 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 967842e2ba0c..0f793663322e 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -134,6 +134,7 @@
SUBDIR += gstreamer1-plugins-v4l2
SUBDIR += gstreamer1-plugins-vpx
SUBDIR += gstreamer1-plugins-x264
+ SUBDIR += gstreamer1-vaapi
SUBDIR += gstreamermm
SUBDIR += gtk-recordmydesktop
SUBDIR += gtk-youtube-viewer
diff --git a/multimedia/gstreamer1-vaapi/Makefile b/multimedia/gstreamer1-vaapi/Makefile
new file mode 100644
index 000000000000..193cb5dd41c0
--- /dev/null
+++ b/multimedia/gstreamer1-vaapi/Makefile
@@ -0,0 +1,38 @@
+# Created by: Koop Mast <kwm@rainbow-runner.nl>
+# $FreeBSD$
+
+PORTNAME= gstreamer1-vaapi
+PORTVERSION= 0.5.7
+CATEGORIES= multimedia
+MASTER_SITES= http://www.freedesktop.org/software/vaapi/releases/gstreamer-vaapi/
+DISTNAME= gstreamer-vaapi-${PORTVERSION}
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= GStreamer hardware video decoding via VA-API plug-in
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libva.so:${PORTSDIR}/multimedia/libva
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_GSTREAMER1= yes
+GNU_CONFIGURE= yes
+USE_GL= gl
+USE_XORG= x11 xrandr xrender xproto:build
+USES= gmake pkgconfig
+CONFIGURE_ARGS= --disable-wayland --with-gstreamer-api=1.2
+PATHFIX_MAKEFILEIN= configure
+
+PLIST_SUB= VERSION=1.2
+
+# manual since pathfix doesn't work.
+post-patch:
+ @${REINPLACE_CMD} -e 's|[{]libdir[}]/pkgconfig|{prefix}/libdata/pkgconfig|g' \
+ ${WRKSRC}/configure
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgst*-1.2.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gstreamer-1.0/libgstvaapi.so
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-vaapi/distinfo b/multimedia/gstreamer1-vaapi/distinfo
new file mode 100644
index 000000000000..206a64aabbe2
--- /dev/null
+++ b/multimedia/gstreamer1-vaapi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gstreamer-vaapi-0.5.7.tar.bz2) = d5a71179669dfc1d529e0248e6929e5136c6b3bbe634826b796f559dae974b88
+SIZE (gstreamer-vaapi-0.5.7.tar.bz2) = 816828
diff --git a/multimedia/gstreamer1-vaapi/pkg-descr b/multimedia/gstreamer1-vaapi/pkg-descr
new file mode 100644
index 000000000000..15685edb6cbb
--- /dev/null
+++ b/multimedia/gstreamer1-vaapi/pkg-descr
@@ -0,0 +1,8 @@
+gstreamer-vaapi is a collection of GStreamer plugins and helper
+libraries that allow hardware accelerated video decoding through
+VA-API. Depending on the underlying hardware, the following video
+decoders are supported: JPEG, MPEG-2, MPEG-4:2, H.264 and VC-1.
+Renderers are available for X11, GLX, Wayland and raw DRM for headless
+pipelines.
+
+WWW: https://gitorious.org/vaapi/gstreamer-vaapi
diff --git a/multimedia/gstreamer1-vaapi/pkg-plist b/multimedia/gstreamer1-vaapi/pkg-plist
new file mode 100644
index 000000000000..2d3a53caff37
--- /dev/null
+++ b/multimedia/gstreamer1-vaapi/pkg-plist
@@ -0,0 +1,52 @@
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_h264.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_jpeg.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_mpeg2.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_mpeg4.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_vc1.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_drm.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_glx.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_wayland.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_x11.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapifilter.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiimage.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiimagepool.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiobject.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapipixmap.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapipixmap_x11.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiprofile.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisubpicture.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisurface.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisurfacepool.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisurfaceproxy.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapitexture.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapitypes.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapivalue.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapivideopool.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_drm.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_glx.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_wayland.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_x11.h
+include/gstreamer-%%VERSION%%/gst/vaapi/video-format.h
+lib/gstreamer-1.0/libgstvaapi.la
+lib/gstreamer-1.0/libgstvaapi.so
+lib/libgstvaapi-%%VERSION%%.a
+lib/libgstvaapi-%%VERSION%%.la
+lib/libgstvaapi-%%VERSION%%.so
+lib/libgstvaapi-%%VERSION%%.so.0
+lib/libgstvaapi-glx-%%VERSION%%.a
+lib/libgstvaapi-glx-%%VERSION%%.la
+lib/libgstvaapi-glx-%%VERSION%%.so
+lib/libgstvaapi-glx-%%VERSION%%.so.0
+lib/libgstvaapi-x11-%%VERSION%%.a
+lib/libgstvaapi-x11-%%VERSION%%.la
+lib/libgstvaapi-x11-%%VERSION%%.so
+lib/libgstvaapi-x11-%%VERSION%%.so.0
+libdata/pkgconfig/gstreamer-vaapi-%%VERSION%%.pc
+libdata/pkgconfig/gstreamer-vaapi-glx-%%VERSION%%.pc
+libdata/pkgconfig/gstreamer-vaapi-x11-%%VERSION%%.pc
+@dirrmtry include/gstreamer-%%VERSION%%/gst/vaapi
+@dirrmtry include/gstreamer-%%VERSION%%/gst
+@dirrmtry include/gstreamer-%%VERSION%%