aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2017-04-20 16:09:04 +0800
committerdecke <decke@FreeBSD.org>2017-04-20 16:09:04 +0800
commit447883358c408c2aa457408768e82058e0241017 (patch)
tree9ef6a0cf20d9d198368c5352fab240d3b4015e93 /multimedia
parentc1cbf7be36e73091f1da6ad1614cfcd32d5110d1 (diff)
downloadfreebsd-ports-gnome-447883358c408c2aa457408768e82058e0241017.tar.gz
freebsd-ports-gnome-447883358c408c2aa457408768e82058e0241017.tar.zst
freebsd-ports-gnome-447883358c408c2aa457408768e82058e0241017.zip
Use correct group in prestart when creating logdir/confdir/pidfile.
Submitted by: Tim Brody <tim.brody@gmail.com> Reported by: Tim Brody <tim.brody@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/tvheadend/Makefile2
-rw-r--r--multimedia/tvheadend/files/tvheadend.in6
2 files changed, 4 insertions, 4 deletions
diff --git a/multimedia/tvheadend/Makefile b/multimedia/tvheadend/Makefile
index 0343984fa090..02356b36dcaa 100644
--- a/multimedia/tvheadend/Makefile
+++ b/multimedia/tvheadend/Makefile
@@ -4,7 +4,7 @@
PORTNAME= tvheadend
PORTVERSION= 4.0.8
DISTVERSIONPREFIX= v
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= multimedia
MAINTAINER= decke@FreeBSD.org
diff --git a/multimedia/tvheadend/files/tvheadend.in b/multimedia/tvheadend/files/tvheadend.in
index 372533a24ba2..e80c1e82c740 100644
--- a/multimedia/tvheadend/files/tvheadend.in
+++ b/multimedia/tvheadend/files/tvheadend.in
@@ -38,13 +38,13 @@ PATH=/sbin:/bin:/usr/sbin:/usr/bin:%%PREFIX%%/sbin:%%PREFIX%%/bin
tvheadend_prestart()
{
if [ ! -f "${pidfile}" ]; then
- /usr/bin/install -o ${tvheadend_user} -g ${tvheadend_user} -m 644 /dev/null ${pidfile}
+ /usr/bin/install -o ${tvheadend_user} -g ${tvheadend_group} -m 644 /dev/null ${pidfile}
fi
if [ ! -d "${confdir}" ]; then
- /usr/bin/install -o ${tvheadend_user} -g ${tvheadend_user} -m 755 -d ${confdir}
+ /usr/bin/install -o ${tvheadend_user} -g ${tvheadend_group} -m 755 -d ${confdir}
fi
if [ ! -d "${logdir}" ]; then
- /usr/bin/install -o ${tvheadend_user} -g ${tvheadend_user} -m 755 -d ${logdir}
+ /usr/bin/install -o ${tvheadend_user} -g ${tvheadend_group} -m 755 -d ${logdir}
fi
}