aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-22 04:46:54 +0800
committermarcus <marcus@FreeBSD.org>2004-02-22 04:46:54 +0800
commit458bb8127b3e7c6c17086fb5b36a3146e46d8349 (patch)
treee5a37800201b52747af5d34833d243c6281c99f8 /multimedia
parenta42e0a13b3b49942aee0bc8788b914427ee9a594 (diff)
downloadfreebsd-ports-gnome-458bb8127b3e7c6c17086fb5b36a3146e46d8349.tar.gz
freebsd-ports-gnome-458bb8127b3e7c6c17086fb5b36a3146e46d8349.tar.zst
freebsd-ports-gnome-458bb8127b3e7c6c17086fb5b36a3146e46d8349.zip
Make sure to link against libc_r on 5.X if requested to do so. This should
fix any DTP-related crash. Obtained from: MarcusCom GNOME 2.5 repo
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer/Makefile2
-rw-r--r--multimedia/gstreamer/files/patch-ltmain.sh21
-rw-r--r--multimedia/gstreamer80/Makefile2
-rw-r--r--multimedia/gstreamer80/files/patch-ltmain.sh21
4 files changed, 32 insertions, 14 deletions
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index ad2ad67f9311..3f7a4303ae02 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gstreamer
PORTVERSION= 0.6.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
diff --git a/multimedia/gstreamer/files/patch-ltmain.sh b/multimedia/gstreamer/files/patch-ltmain.sh
index 1c2fba5d533f..284a2d7b15df 100644
--- a/multimedia/gstreamer/files/patch-ltmain.sh
+++ b/multimedia/gstreamer/files/patch-ltmain.sh
@@ -1,6 +1,15 @@
---- ltmain.sh.orig Fri Sep 13 15:38:11 2002
-+++ ltmain.sh Fri Oct 11 01:44:24 2002
-@@ -1073,8 +1073,16 @@
+--- ltmain.sh.orig Mon Oct 13 14:17:09 2003
++++ ltmain.sh Sat Feb 21 15:44:32 2004
+@@ -1075,7 +1075,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1085,8 +1085,16 @@
continue
;;
@@ -17,8 +26,8 @@
continue
;;
-@@ -2502,6 +2510,9 @@
- *-*-openbsd*)
+@@ -2503,6 +2511,9 @@
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc due to us having libc/libc_r.
;;
+ *-*-freebsd*)
@@ -27,7 +36,7 @@
*)
# Add libc to deplibs on all other systems if necessary.
if test $build_libtool_need_lc = "yes"; then
-@@ -4286,10 +4297,12 @@
+@@ -4330,10 +4341,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/multimedia/gstreamer80/Makefile b/multimedia/gstreamer80/Makefile
index ad2ad67f9311..3f7a4303ae02 100644
--- a/multimedia/gstreamer80/Makefile
+++ b/multimedia/gstreamer80/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gstreamer
PORTVERSION= 0.6.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
diff --git a/multimedia/gstreamer80/files/patch-ltmain.sh b/multimedia/gstreamer80/files/patch-ltmain.sh
index 1c2fba5d533f..284a2d7b15df 100644
--- a/multimedia/gstreamer80/files/patch-ltmain.sh
+++ b/multimedia/gstreamer80/files/patch-ltmain.sh
@@ -1,6 +1,15 @@
---- ltmain.sh.orig Fri Sep 13 15:38:11 2002
-+++ ltmain.sh Fri Oct 11 01:44:24 2002
-@@ -1073,8 +1073,16 @@
+--- ltmain.sh.orig Mon Oct 13 14:17:09 2003
++++ ltmain.sh Sat Feb 21 15:44:32 2004
+@@ -1075,7 +1075,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1085,8 +1085,16 @@
continue
;;
@@ -17,8 +26,8 @@
continue
;;
-@@ -2502,6 +2510,9 @@
- *-*-openbsd*)
+@@ -2503,6 +2511,9 @@
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc due to us having libc/libc_r.
;;
+ *-*-freebsd*)
@@ -27,7 +36,7 @@
*)
# Add libc to deplibs on all other systems if necessary.
if test $build_libtool_need_lc = "yes"; then
-@@ -4286,10 +4297,12 @@
+@@ -4330,10 +4341,12 @@
fi
# Install the pseudo-library for information purposes.